Garrysmod hl2.exe crashes upon joining multiplayer.

Pretty self explanitory. Singleplayer works fine, but when I try to connect to a multiplayer server, it starts loading/connecting like normal then it just closes out and that dreaded “hl2.exe has stopped working” pops up.

I have tried:
-dxlevel 81
-re-install
-booting in singleplayer, then joining the server

Also, I am not using a firewall other than microsoft MSE, and the basic firewall allows gmod and hl2.

What do I do, guise?


(User was banned for this post ("wrong section" - postal))

Have you tried posting in the right section?
Have you tried reading the forums? There are LOADS of posts explaining a solution to this very problem
Have you tried vgui_allowhtml 0 ?

I’m having the very same problem and was about to create a similar topic [sinse for some reason I don’t have permission to use the “Search” section on this forum].

I already tried:

  • Disable Steam Overlay;
  • Start up Garry’s Mod from a fresh reboot;
  • Check game cache integrity on Steam;
  • Disable all Extensions;
  • Delete the garrysmod folder from my Steam ID folder;
  • Update my graphics card driver to the latest version from the manufacturer site.

I’ve sucessfully joined a Garry’s Mod multiplayer game about a month ago, then I stopped playing for a while and now this…

As Bender said, the problem only happens on Multiplayer games, either I’m creating a server (both LAN or Internet) or joining an existing one.

The exact error I get is:

**The instruction at “0x16ac3571” referenced memory at “0x0f7edfe4”, The memory could not be “read”. Click on OK to terminate that program.
**

I have a couple crash dumps, but I’m not sure if I should post this sort of stuff here.

[editline]16th September 2012[/editline]

“vgui_allowhtml 0” seemed to fix the problem, at start. But suddently I got the very same crash again minutes later. Is there any other solution to this problem?

did you happen to restart your game between when it was and wasnt working

Apparently it happened only once, not sure why. Now its ok.

The “vgui_allowhtml 0” solution is ok, but you need to write this each time when you enter in the game.

I have got the same problem. If its not crashing while loading the server, it stucks in loading screen when it is sending the clientinformations. I tried all ways you explained in here. Singleplayer works fine - absolutly no problems - only the thing with the multiplayer. Please help!