Garrysmod Not Starting Up

Hey Facepunch,

So for about a week now (I suppose), GMod hasn’t launched right. I’ll select it from my steam library and launch it, and it goes into fullscreen and to the initial loading page (With the guy holding the toolgun and physgun on gm_construct)

Once it gets there, it won’t do anything. It has the “Loading” thing in the bottom right corner, and my cursor is stuck on the spinning “loading” circle. I can’t do anything then except ctrl+alt+del and go to task manager. When i get there, it always says that GMod/Hl2 isn’t responding.

Now, before you tell me the obvious suggestions, I’ve updated my graphics card’s drivers, Reinstalled Gmod, and have tried restarting it many times.

If anyone needs the specs, my card is an ATI Radeon HD 4300/4500 series. I’ve got 4gb RAM, and a quad-core 2.67 ghz Intel i5 processor.

Thanks in advance for any help.

It happens to me and my IRL friend as well.

It lets us play after 5 minutes of waiting.

I’m having this issue too, I left it for about half an hour and still nothing.

Edit: Is it just garry’s mod? Are other source games starting?

Edit2: I launched another source game and then Garry’s Mod worked perfectly. Give that a shot.

Yeah, the other source games were starting. Thanks for that idea, I’ll try that.