Garrysmod startup failing

I am having issues starting up garrysmod. i get the hl2.exe error whenever i try to load up garrysmod. Im trying to access garrysmod through an external hard drive i have. Apparently i tested other games like Day of Defeat which managed to work fine. I already tried to fix my problem by copying my whole steam folder to my computer from my external hard drive and play it from there but didnt work. I then tried reinstalling it on my computer but it didnt do anything. So i deleted the copy of my steam that was on my computer because i already have it on my external hard drive. Help would be appreciated very much.

PLEASE HELP ME!

Well, I have a few theories.

  1. That disk is very scratched
  2. You should probably reinstall that game
  3. Wait for another post from someone more helpful then I am

Garrysmod doesnt come on a disk and I already tried to reinstall.

do you have Team Fortress 2?

They had an update a few days ago that had a side affect of making GMod full when it was starting up. (this might have been fixed, not sure).

If you do have TF2, read this thread

No I do not own TF2, any other ideas?

Reinstalling Garry’s mod. Thats what I did with my Episode 2 to make it real models.

Already tried a decent amount of times. After couple of hours of trying, i decided to seek help which i have been doing now for this site. Any other ideas?

Reinstall everything (From steam). If your that very desperate, reinstall computer.

already got computer wiped because of a virus. Its only a hl2.exe error. Any other ideas?

Delete the hl2.exe and play again. It should re-install it while loading.

My computer is wiped but i have an external drive plugged into my computer right now via usb. all my fiels that were on my computer is on my external so id rather not wipe that.

[editline]12:43AM[/editline]

okay

Well, I ran out of my hat-tricks.

Thank for the quick idea for a fix. I’ll try your idea of reinstall. Thanks

[editline]01:14AM[/editline]

I tried reinstalling half life 2 but the “hl2.exe encountered a problem” crash just keeps happening whenever i try to load up halflife 2 and garrysmod. Please assist!

Try moving Steam and your Steam apps to your main computer, and not your external.

I figured out the problem. I added Direct X which fixed it i guess. I tried 1 other solution which might of worked but, cant explain. ehe