Garrysmod wont open?!

Alright so when i go to open up garrysmod the “preparing to launch garrysmod” will come up but then go away really fast and garrysmod wont open. I wont get a error or anything though. And when i go to run anyother game like Counterstrike Source it works fine. Help please?

Ps. It was working before this weekend and i havnt done anything to it since.

EDIT - Now when i try to open Gmod it now says “hl2.exe has encountered a problem and needs to close.”

EDIT - Reinstalled steam again. Getting hl2.exe error

Try reinstalling garrysmod, that might work

Did that. I also reinstalled steam. Still nothing.

ok please people do not say i am troling this will most likely work for this issue.

Shut off steam, go to the steam install directory and delete ClientRegistry.blob and AppUpdateStats.blob empty your recycle bin, restart your computer and start up steam.

Thanks for trying to help but it didnt work >.< I honestly dont know whats wrong! I really just wanna play gmod!

From the Help and Support FAQ:

You all should look there next time before posting, or helping with a problem.

ok another solution is here and this could help. Right click on garrysmod, go to properties and set launch options and paste in there -dxlevel 80

Neither of these solutions worked.

That’s incorrect. You’re supposed to set it to:


-dxlevel 81

Also, add this and give it a go:


-windowed -noborder

Didnt work. I wish i knew what was wrong! Please help :frowning:

Do you own Garry’s Mod? And/Or use some sort of Steam hack? (Just need to make sure, a link to your steam profile would be preferable)

I do own Garry’s Mod. and no steam hacks . I was just using garrysmod before this weekend and it worked like a charm.

Steam account link - http://steamcommunity.com/id/sadkitty

What are all of your launch options?

I tried the ones mentioned but i dont have any launch options because they didnt work.

What engine is Garry’s mod on now? It probably wouldn’t hurt to run a similar source game running that engine, just for kicks and grins. (I doubt it’s what CS:S runs on.)

Otherwise, I’ll go for the usual troubleshooting step and say check for updates. That includes Drivers and general windows.

[editline]12:11AM[/editline]

Also, anything unusal in the error logger?

Control panel -> Administrative Tools -> Event Viewer, then check the Application and System categories.

Alright so more info. When i go to open garrysmod i got that error and i went to go see the error report and it said this -

AppName: hl2.exe AppVer: 0.0.0.0 ModName: shaderapidx9.dll
ModVer: 0.0.0.0 Offset: 0002a736

So i thought maybe “shaderapicx9.dll” was the problem so i went to delete it and i did and when i went to start up gmod it just made another one so… help?

I’m pretty sure you’re supposed to leave it where it is. It seems like, however, garry’s mod is crashing due to a DirectX problem.

Go here and download/install the DirectX Runtime Web installer. This will completely update DirectX 9.0c (and older libraries, apparently) to their latest available versions.

Once that’s done, try launching gmod again.

Nope . I tried to install and it said i already had the latest version :confused: FFS i want this to work >.<

You’ve already downloaded that exact file?

Are you sure you’ve tried the dxlevel solution?

In steam, right click Garry’s mod and go to properties, then click Set Launch Options…, then type in -dxlevel 81. Then launch gmod.

If that works, then… we’ll have to dive deeper into directx diagnosing.

And you did put that file back, didn’t you?

Yeah i downloaded that file and when i tried to install it it said it already found the latest version and i used that command still nothing :frowning: and yes i did put that file back