GCombat weapon limit hit before owning a weapon, how to fix?

How would I set the limit for gcombat weapons to more than uh, 0? I try to spawn a weapon and it just says I hit the limit.

if you’re in mp, it’s the server. if in sp, try setting the entity limit to something more than 0.

I’m having the same problem and desperately need a fix.

I’m having the same problem. On my own fucking server and there is no command that can change this “weaponlimit”.

Well those who are still having this problem and those who encounter it, I’ve edited the GCX files to ignore the weapon limit altogether. This is only a temporary fix as I have no clue what the console command is. Nevertheless, the download is here http://www.mediafire.com/download.php?gcnvkzlazzn

sbox_max_gcombat 500
I think.

slaps head

No. before you even JOIN the server, when you’re still doing the server joining, it has the window to choose maps and settings. go to the settings tab, and find the slider that sets the limit of entities. set that to something other than zero.

That doesn’t even remotely make sense. Do you mean the main menu? cause once you are joining a server all you can DO is wait, or cancel.

Did a “Search In Files” with Notepad ++. According to the results, there are two commands:


sbox_maxrazers (<-- Only for GCX)
sbox_maxgcombat

FINALLY, you are the best!

That does not work for. It says (Unknown command: sbox_maxgcombat)

I’m still searching for that command. Me and my friend want to spawn those guns. The GDC guns. Also i can spawn GCOMBAT08 guns, but they are screwed up full of errors.

I sincerely apologize for the super bump, but I’ve searched everywhere around the forums and have found nothing.

I LOVE YOU ! IT Works !

only “sbox_maxrazers” works, but that unlocks just one weapon. nothing else works :frowning:
in single player everything works just fine but when i host a server nothing works.