Getting custom content & EmitSound to work

I’m struggling to figure out why the custom content I add does not work. I’m trying to add custom fonts and sounds, I’ll start with the sounds.

“Failed to load sound ‘sound aunts\ellis\mynameisgabenewell.wav’, file probably missing from disk/repository” is the error I get. In garrysmod/addons/blabla/lua/autorun/server/dl.lua I have the line resource.AddFile(“sound/taunts/ellis/mynameisgabenewell.wav”), in garrysmod/addons/addon_pointshop/sound/taunts/ellis I have my sound files (.wav) and in garrysmod/addons/addon_pointshop/lua/pointshop/items/playermodels/ellis.lua I have this:


function ITEM:Move( pl, modifications, ply, data)
	if pl ~= ply then return end
	local bdata = data:GetButtons()
	if bit.band( bdata, IN_ATTACK ) > 0 then
		ply:EmitSound( Sound( "sound/taunts/ellis/mynameisgabenewell.wav" ), ply:GetPos(), 1, CHAN_AUTO, 1, 75, 0, 100 )
	end
end

Obviously it can’t load the sound file, but how can I make it then? Is the AddFile not done correctly? I tried to add the AddFile line into the ITEM:Move function but it didn’t work there either.

As for the custom font, the font is located in garrysmod/addons/addon_pointshop/resource/fonts/CaviarDreams_Bold.ttf, the resource.AddFile is in the same dl.lua as the one mentioned above, and the code I’m trying to execute looks like this:


surface.CreateFont( "CIV_Main", {
	font = "CaviarDreams_Bold",
	size = 32, weight = 500, antialias = true,
})

draw.SimpleText(PS.Config.CommunityName, 'CIV_Main', 16, 8, color_white)


The result of the code above is not the custom font, but instead what I assume is the “backup” or whatever it’s called that displays if the custom font doesn’t work.

Thanks in advance.

In


ply:EmitSound( Sound( "sound/taunts/ellis/mynameisgabenewell.wav" ), ply:GetPos(), 1, CHAN_AUTO, 1, 75, 0, 100 )

Avoid the use of Sound() in ply:EmitSound() and remove “sound/” of the path.


ply:EmitSound("taunts/ellis/mynameisgabenewell.wav", ply:GetPos(), 1, CHAN_AUTO, 1, 75, 0, 100 )

For the custom font, it’s another problem.

Thanks a lot mate, the sound works now.
What do you mean with “another problem”?

For the font, the name should be Caviar Dreams. (You can view the name from opening the font file, and then it says ‘Font Name:’ at the top)

Oh I see! Thanks a lot to both of you, much appreciated :slight_smile: