Getting Disconnected: Easy Anti Cheat - Disconnected

I am Getting “Disconnected: Easy Anti Cheat - Disconnected” after 10-20 sec after joining on every server i try to join.
Cant play as it is now, eanyone have eany fix at this point?

ddi you find a solution? because this is driving me up the wall!

Hi,

Have you launched the game directly from Steam?

yes, if i launch rust through steam it will give an error:

“EasyAntiCheat
Bug report successfully sent.
Thank you very mutch!”

Everytime when launched from steam, i have to launch the rust client manualy atm.

Then anti-cheat is never loaded so you cannot play on secure servers.

Do you get an error message when launching the game from Steam? Other than about bug report was sent.

What’s the last 2 digits of your IP address, so that I could check from database your report specifically? (xxx.xxx.123.123)

194.78

I had the same problem … this works for me …

Anti–Virus Compatibility

EasyAntiCheat has no known compatibility issues with anti–virus software, except with the following products.

Bitdefender
Bitdefender’s stealth mode is incompatible with EasyAntiCheat. To resolve this issue open Bitdefender security center > under firewall select manage adapters > disable stealth mode in the drop down menu.

COMODO
To resolve issues with COMODO you can add the game executables to the firewall exclusions by going to Advanced Settings > Security Settings > Defense++ > Behavior Blocker > Exclusions.

@DeathKillerNO: Something in your system is causing incompatibility and the process start to fail.

Check that you don’t have some very old anti-virus installation in place that has boot driver loading on Windows start. This specific error is almost always caused by corrupted AV installation where the AV is not working but its driver is loaded on Windows boot anyway.

Got no anit-virus currently installed. resenty formated too so no old install is on the drive.
Firewall is also currently disabled.

i am getting “Disconnected: Easy Anti Cheat - disconnected” I am not able to play rust at the moment. Any ideas on how to fix this?

Me too:/

I really need a fix for this right now

Just double checking, are you launching the game from Steam?

no, the error comes up everytime i launching the game from steam.
Cant runn it from steam at this point.

If you don’t launch the game from Steam, then the anti-cheat is never loaded and the server will kick you. We will need to resolve the error for you first.

Hi since today every time i played i was disconected from the server and i have Easy Anti Cheat - Disconnected in the console.

https://imageshack.com/i/iqHDlswDp

I play on Mac OS X 10.8.5 and i lunch the game from steam.
the two last digit of my IP is 136.99 .

Hey guys,

This problem may be related to another EAC error. Installing the EAC client manually will cause this kind of problem. Try this fix HERE, it may solve this issue.

NOTE: If you have not done so already, please manually install the EAC client; it can be found in the EasyAntiCheat folder located in the “Steamapps/Common/Rust” folder.

Cheers,

GoodGuyGrant.

That solution fixes the problem with launching rust from steam but doesn’t stop the “Easy Anti Cheat - Disconnected” issue.

The issue is happening for me in both Mac OS X 10.10 and Windows 8.1

Hey guys,

I have the same disconnection issue since this morning (last update). Was working perfectly before.
I’m playing on Mac OS X 10.10.
Kick-off from the servers after 10 sec (Easy Anti Cheat - Disconnected in the console). I tried a variety of servers. Same effect.

I reinstalled Rust. No change. Legacy is still working fine.

Concerning EAC Client, there is no EAC folder in my “Steamapps/Common/Rust”, only folders named : cfg, html and legacy

Steam is allowed in my Firewall settings.

EDIT: I just tried to open it from launchpad and it worked at least on 1 server. Sadly, after some hours of game this server seems blocked now and I can’t join it anymore.

EDIT 2: 1 day after, I succeeded to join this server again, but now the server is now kicking me off as others (EAC - disconnected …).

did try follow this —>http://steamcommunity.com/app/252490/discussions/0/613940477811782261/
noticed i got a file that didnt have a value so i change it to the value this post said it should be.
Rust is updating now so we will see if it works after this update.

Edit: it did not

Edit: Then i did try this one —> http://www.reddit.com/r/playrust/comments/2kzjuh/rust_wont_run_anti_cheat_engine_issue/, witch did not work either.

Could you add me in Steam and we could debug this issue tomorrow over TeamViewer, if possible? http://steamcommunity.com/profiles/76561197999579793