getting fretta to work dedicated server

I tried turning my dedicated server (off of my home pc) into a fretta one. I set it up correctly, downloaded 2 fretta gamemodes, and maps for both of them. I start it up, and press f1 to vote for a real gamemode (not the base) and the gmod tutorial window pops up. Please help! I don’t know how to fix this

bump, i need help on this badly

Does it say it’s set at Fretta?

1.does what say it’s set to fretta, and 2. It says fretta_(base-gamemode-pallet) or something, it let’s me join one of 5 teams, then I spawn, and I can’t access any fretta menus or anything.

bump, i need this help fast, the server community i joined is a-watin

  1. Your server when you join it from the servers list
  2. Any errors?
  3. Run hldsupdatetool -command update -game “garrysmod” -verify_all. I was missing the shared.lua for w/e reason.

ill try that. quotation marks or not?

I just do the quotation marks as a habit. I think you can get off fine for just garry’s mod, but when you have a game with more than one word (separated by a space), then I think you need them.

So my answer in this case is: no.

ok, thanks. ill respond as soon as thats done. thanks for trying to help
EDIT: SHIT im getting the hldsupdatetool is not recognised as an internal or external command error again >.> cant remember how i fixed it the last time :X
EDIT: fixed the updatetool error, ill get back to you when its dont verifying all the files ect

In command prompt, use the command cd (standing for change directory) to move to the directory where hldsupdatetool is. For example, I installed my server to C:\srcds, so I would type cd C:\srcds, then hldsupdatetool xxxxx.

right, thanks. i got confused between the destination folder and the resource one :stuck_out_tongue_winking_eye: :ms:

ill post saying weither it worked or not after it finishes verifying

[editline]05:42PM[/editline]

when i try to run srcds now i get the error “failed to load the launcher.dll the specified module could not be found”

Anything unusual while you were running hldsupdatetool? I think I remeber this problem a loooong time ago…
I think it may have had something to do with installing team fortress 2 in the dedicated server folder. Did you happen to do that?

no. the only other thing i installed was css and i removed it, as a fretta server would not need it

Well, sometimes you may need to run hldsupdatetool. (Not quite sure why, just a phenomenon sometimes.) So go ahead and run hldsupdatetool -command update -game garrysmod. (Oh, also, give hldsupdatetool -command update -game orangebox a try.)

k. thanks for all the help, your awsome
EDIT: now it appears to be downloading a folder titled srcds2/orangebox\orangebox… im going to let it run its course and see what happens

[editline]08:25PM[/editline]

nope, still the same goddamn error :confused:

-snip-

Whoops, I was way off. (And I knew that I had seen this problem before, too!)

The command line you’re using to start the game up is wrong.

Be absolutely sure that it reads very close to this:



c:\srcds2\srcds.exe -console -game garrysmod


And then of course, you can add whatever cvars and whatnot you want on the end. But it has to look like that. (Of course the path will be different if you have it in a different directory.)

If that still doesn’t work, paste your startup line here, along with the directory location for /garrysmod.

wait. im using the gui version, and also, my srcds is in srcds2/orangebox.

Ah, ok.

Intersting. Hldsupdatetool has obviously done something.

I’m beginning to think you may have set the -dir argument incorrectly at one point. The dir argument should always point to the root of the srcds directory. You said there’s now a folder called srcds2/orangebox/orangebox? Delete the second orangebox, it shouldn’t be there. Then run these commands now:



hldsupdatetool -command update -game garrysmod -dir "C:\srcds2"
hldsupdatetool -command update -game orangebox -dir "C:\srcds2"


While of course, the dir must end up in srcds2.

good news: srcds works!
bad news: fretta dosent! :byodood:

Ah, so the dir command fixed it?

Is fretta still having the exact same problem?