Getting Lua Errors when joining my server.

I receive the following Errors when joining, i do not see anymore errors above these. I am an amateur at Lua coding.
[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_data.lua:415: attempt to index a nil value

  1. retrieveSalary - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:415
  2. callback - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:440
    3. callback - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:333
    4. query - gamemodes/darkrp/gamemode/libraries/mysqlite/mysqlite.lua:305
    5. offlinePlayerData - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:305
    6. retrievePlayerData - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:344
    7. restorePlayerData - gamemodes/darkrp/gamemode/modules/base/sv_data.lua:431
    8. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:587

[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:606: attempt to index local ‘jobTable’ (a nil value)

  1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:606

[ERROR] gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:729: attempt to index local ‘jobTable’ (a nil value)

  1. unknown - gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua:729

[Krillinu|2|STEAM_0:1:51119106] Lua Error:

[ERROR] lua/includes/extensions/math.lua:156: attempt to perform arithmetic on local ‘num’ (a nil value)

  1. Round - lua/includes/extensions/math.lua:156
  2. DrawHUD - addons/ahud/lua/ahud/ahud.lua:207
    3. fn - addons/ahud/lua/ahud/ahud.lua:428
    4. unknown - addons/ulib/lua/ulib/shared/hook.lua:109

Any help? I can put in more info if needed?

You edit Dark RP core files?

I don’t know much about how DarkRP works but it looks like you fucked up your jobs.

I edited the darkrp gamemode file init.lua, but restored it back. Can’t understand what i’ve done wrong to cause this. Still haven’t fixed it.

Its your hud addon it says
2. DrawHUD - addons/ahud/lua/ahud/ahud.lua:207
3. fn - addons/ahud/lua/ahud/ahud.lua:428

That’s a seperate error.

It seems to me that you messed up with a salary.
Make sure it is not a nil value.

All the salaries look fine, if needs be i can send a txt of our jobs.lua.

That’s just the HUD calling the DarkRp vars which are fucked.

I’ve had this issue before where it was caused by a corrupted database, this might not be exactly your issue but you could attempt to reach out to your hosting (in case you’re using a hosting).