Getting models into Garrysmod

Hello.

I have been trying for four days straight trying to get a static model from blender or 3dsmax into garrysmod. Ultimately, I want to get models into the hammer editor.

I have gone through all these tutorials.

http://www.facepunch.com/showthread.php?t=734991

Every one of them I have not been able to complete. Theres a common problem im having with all of them. When it becomes time to compile, theres always an error message that I simply cannot find a way around. I have gone through each one thoroughly.

I dont know a thing about programming. So everythings new to me.

Alright, so let me narrow my problem down. Currently im trying to learn cannonfodder’s StudioCompiler. Following this tutorial http://www.gamebanana.com/tuts/168. The problem is, after I think i’ve put everything in correctly I hit compile. I am getting error messages for both the model and material compiles. I will provide as much information as I can. Below are screenshots I have of the cannonfodder window and the error messages.

note: The only game I own is garrys mod.

note: The octopus model has 5 image textures. 4 of them are just flat colors and 1 of them is the skin texture.

help is very appreciated!

hey can you try rigging the mannequin model from silent hill? please :slight_smile:

Well your bigger issues seem to actually be getting the thing to compile in the first place.
Have you tried going trough this tutorial for basic pointers?
Those put forward some basic compiling stuff forward too

the link you posted goes to a google search and not any tutorial. So im not sure what to do…

i dont know how to rig a model can someone rig the silent hill mannequin to gmod for me please it would be nice if someone would do it cause i dont know how to do it :frowning:

Sorry my mistake
http://www.facepunch.com/threads/542906

Go to the requests section to request a model.

I will look through that tutorial. But im not trying to make a ragdoll. Just a static prop.

What im most concerned about is why I keep getting an error messages saying, please select correct HL2 SDK path using the configure button. The top screenshot shows my file paths for the configure options.

Also, why for the textures does it say, unable to create TGA file?? I thought it’s suppost to turn them into VTF and VMT files. They are already TGA’s.

try making a qc rather than try to autogenerate it then use GUIstudiomdl to compile it, its not that hard



$modelname	"props_sdk\myfirstmodel.mdl"
$body mybody	"myfirstmodel-ref.smd"
$staticprop
$surfaceprop	combine_metal
$cdmaterials	"models\props_sdk"

$sequence idle	"myfirstmodel-ref.smd" // no animation wanted, so re-using the reference mesh

$collisionmodel	"myfirstmodel-phys.smd" { $concave }

And use VTFedit to make the textures

And the vmts are quite simple



"VertexLitGeneric"
{
	"$baseTexture" "models\pathtovtf"
}

Heres the message I get when I try to use your qc file. I have already tried the tutorials where you make a qc file but to no avail

GUIStudioMDL 2.2/Source - © 2007 Neil ‘Jed’ Jedrzejewski - http://www.wunderboy.org/

Loaded QC file - “C:\Program Files (x86)\Steam\steamapps\skywalker113\garrysmod\garrysmod\models\props\octopusSDK\octopussdk.qc”

Created command line: “C:\Program Files (x86)\Steam\steamapps\skywalker113\sourcesdk\bin\orangebox\bin\studiomdl.exe” -game “c:\program files (x86)\steam\steamapps\skywalker113 eam fortress 2 f” -nop4 -nox360 “C:\Program Files (x86)\Steam\steamapps\skywalker113\garrysmod\garrysmod\models\props\octopusSDK\octopussdk.qc”

qdir: “c:\program files (x86)\steam\steamapps\skywalker113\garrysmod\garrysmod\models\props\octopussdk”
gamedir: “c:\program files (x86)\steam\steamapps\skywalker113 eam fortress 2 f”
g_path: “C:\Program Files (x86)\Steam\steamapps\skywalker113\garrysmod\garrysmod\models\props\octopusSDK\octopussdk.qc”
Building binary model files…
Working on “octopussdk.qc”
SMD MODEL octopussdk.smd
ERROR: ‘EXCEPTION_ACCESS_VIOLATION’ (assert: 1)
ERROR: Aborted Processing on ‘props_sdk\octopussdk.mdl’
WARNING: Leaking 1 elements

ERROR: ‘EXCEPTION_ACCESS_VIOLATION’ (assert: 1) //try compiling with hlmv open
WARNING: Leaking 1 elements //your trying to compile into a folder that doesn’t exist

[QUOTEWARNING: Leaking 1 elements //your trying to compile into a folder that doesn’t exist[/QUOTE]

where does it ask me to choose a folder to ‘compile’ to? It just wants a qc file and a game info directory I think.

btw, everytime I open GUIStudioMDL. It ask me to choose the configs for orangebox tools path and ep1 tools path. I keep setting the paths but once I close the program, it asks for it again. How do I save? Also, ep1 tools path does not work for some reason. The error message says…

game information could not be found in the gameinfo.txt file. The game/mod can’t be added to the selection list.

Im choosing this path for it…

C:\Program Files (x86)\Steam\steamapps\skywalker113\sourcesdk\bin\ep1\bin

thanks guys!

re-install the sourcesdk something tells me its corrupted

Firstly, your source sdk tools path should be:

C:\Program Files (x86)\Steam\steamapps\skywalker113\sourcesdk\bin\source2009\bin

Second, you need to create the .mdl’s model folders yourself so that GUIStudioMDL can put it in there. See if that’ll fix some things…

[quote]

The leaking 1 element actually means that it cannot find a file specified.
In this case
SMD MODEL octopussdk.smd

In your QC I recommend you specify a $cd which points to the folder from where the compiler will look for the various SMD, VTA and other filetypes ot use in the compile process.

here’s an example Prop QC file



// indicates the folder in which all your files are
$cd "E:\My scribbles\!3d_projects\!planned\light_props"

// indicates where to compile to
$modelname		"kit\props\flat_light.mdl"

// defines the prop is a static prop 
$staticprop

//where the model will look for textures (always gamedir\materials)
$cdmaterials		"models\kit\props"

$texturegroup skinfamilies
{
	{ "light_off"  }
	{ "light_on" }
}

// defines what SMD to use as the model itself. Body for props, Model for ragdolled meshes
$body		light	"flat_light_ref.smd"

//default idle animation, always needed
$sequence	idle	"flat_light_ani.smd"	// A default animation is still required

//collision SMD - collisionmodel for a nonragdolled prop, collisionjoints for a ragdolled model
$collisionmodel       "flat_light_ref.smd"


One more think - the compiler does not have the capacity to create folders itself, you have to make those on your own.

I tried C:\Program Files (x86)\Steam\steamapps\skywalker113\sourcesdk\bin\s ource2009\bin. When I hit compile a window called StudioMDL Status pops up and starts to do something. Although now im getting new errors once it starts to compile. I will break down each problem in separate paragraphs. Here is what it says in the window.

C:/Program Files (x86)/Steam/steamapps/skywalker113/sourcesdk/bin/source2009/bin/studiomdl.exe -game “C:\Program Files (x86)\Steam\steamapps\skywalker113\garrysmod” “C:/Program Files (x86)/Steam/steamapps/skywalker113/garrysmod/garrysmod/models/props/octopusSDK/octopusSDK.qc”
WARNING: AppFramework : Unable to load module p4lib.dll!
WARNING: Unable to find
gameinfo.txt. Solutions:

  1. Read http://www.valve-erc.com/srcsdk/faq.html#NoGameDir

Run vconfig to specify which game you’re working on.
3. Add -game <path> on the command
line where <path> is the directory that gameinfo.txt is in.

Unable to find gameinfo.txt.
Solutions:

  1. Read http://www.valve-erc.com/srcsdk/faq.html#NoGameDir
  2. Run vconfig
    to specify which game you’re working on.
  3. Add -game <path> on the command line
    where <path> is the directory that gameinfo.txt is in.

1.I tried going to http://www.valve-erc.com/srcsdk/faq.html#NoGameDir. The only thing I get is a blank white window.

2.On the part where it says ‘run vconfig’. I clicked on that application but I get this error message. This error message applies to all of the locations where the vconfig application icon is. except sourcesdk\bin\ep1\bin

MountAppFilesystem() failed:
SteamMountAppfilesystem(4294967295,4294967295,0x4b3fd24) failed with error 4
Bad launch configuration

when I try to run the vconfig application from the sourcesdk\bin\ep1\bin. I get another error message saying

The program can’t start because steam.dll is missing from your computer. Try reinstalling the program to fix this problem.

3. The part where it says Add -game <path> on the command line where <path> is the directory that gameinfo.txt is in. I am lost on this part. What command line does it speak of? As far as I know, the cannonfodder studiocompiler did not ask me for a gameinfo.txt

Im not sure what you mean. Should it just be a folder called <modelname>.mdl? Where should the folder be placed?

Alright, here we go…

Upon opening up GUIStudioMDL, with the configuration staying the same like I suggested in my previous post, do you see the Target Mod or “GameInfo” path? Click Add, and a new window should appear. Upon viewing that window, you must navigate over to your garrysmod location, being “usernamehere\garrysmod\garrysmod”. In there, you will find a text document called “gameinfo”. Select that, and click Open. Your Target Mod is now configured…

Now with the .mdl, go into the same place where your gameinfo.txt is located. Open up the folder named models and create a new folder named “props”. If that’s already there, then open it up and make another new folder named “octopusSDK”. Now in GUIStudioMDL, if it’s still open, click compile…

Will that fix everything? I can be more thorough if you like.

I used wraithcats qc. and Treevis121’s instructions, but im still getting more or less the same errors. (I wasn’t sure if I was suppost to remove the descriptions in the qc file so I just left them in).

GUIStudioMDL 2.2/Source - © 2007 Neil ‘Jed’ Jedrzejewski - http://www.wunderboy.org/

Added game config - “Garry’s Mod”

Loaded QC file - “C:\Users\THOLDEN\Desktop\octopusD\octopussdk.qc”

Created command line: “C:\Program Files (x86)\Steam\steamapps\skywalker113\sourcesdk\bin\orangebox\bin\studiomdl.exe” -game “C:\Program Files (x86)\Steam\steamapps\skywalker113\garrysmod\garrysmod” -nop4 -nox360 C:\Users\THOLDEN\Desktop\octopusD\octopussdk.qc

qdir: “c:\users holden\desktop\octopusd”
gamedir: “C:\Program Files (x86)\Steam\steamapps\skywalker113\garrysmod\garrysmod”
g_path: “C:\Users\THOLDEN\Desktop\octopusD\octopussdk.qc”
Building binary model files…
Working on “octopussdk.qc”
ERROR: c:\users holden\desktop\octopusd\octopussdk.qc(20): - could not load file ‘C:\Users\THOLDEN\Desktop/octopusSDK_ref.smd’
ERROR: Aborted Processing on ‘models\props\octopusSDK’
WARNING: Leaking 1 elements

Don’t use the studio compiler.
Just start the source SDK, set the game you want to and drag and drop your QC on top of studiomdl.exe

Also the compiler still cannot find your SMD. Not sure what you’re doing with it.

Do you have that octopusSDK_ref.smd in your octopusd folder, or is it on your desktop? If it’s not on your desktop, then get it there.

This is fun. :stuck_out_tongue: