Glowing texture question?

So I’m porting something from Duke Nukem Forever and I noticed it has 3 files, the main texture, a normal, and something ending with an _E. Now judging from the texture I think it might be for the glow, maybe not since I never really toyed around with these files before. Anyway I wanna know if there is a way I can use it with the main texture without making the main texture itself glow , I looked at the Valve Developer wiki and it said something about $selfillummask but that didn’t work. Any help would be great

Textures

Main
http://uppix.net/a/6/8/b406c4a69e56766facb2a12c524a9.jpg

The believe to be glow texture
http://uppix.net/c/5/e/0dda11683e4e5603e97dd6ff4724e.jpg

I got something fer ya:



	"$detail" "models/Halo/Covenant/Vehicles/Banshee/BansheeChassis_Emis"
   	"$detailscale" "1"
   	"$detailblendfactor" "1.25"
   	"$detailblendmode" "5"


So like so? Cause it doesn’t seem to show up in Model Viewer


"VertexlitGeneric"
{
	"$basetexture" "Models/Jason278/Duke Nukem Forever/Microwave_cd"
	"$bumpmap" "Models/Jason278/DUke Nukem Forever/Microwave_n_cd"
                "$detail" "models/Jason278/DUke Nukem Forever/Microwave_e12_cd"
   	"$detailscale" "1"
   	"$detailblendfactor" "1.25"
   	"$detailblendmode" "5"
}

that should do it, turn the blend factor up, and make the ambiance lighting in HLMV black, and move the light away

Well I did turn off the normal maps in viewer and it sorta popped up but like this
http://uppix.net/0/d/c/3b64a35bfdc98343ec394adda5792.png

It seems the most efficient way to get it to glow would be to use:

$selfillum 1
$surfaceprop glass

Selfillum uses the alpha channel on the diffuse texture to gauge glowiness (White completely illuminated), black not at all)

so the best way to do it like this would be to put that text on the diffuse texture, then make the alpha channel have only that text in the same place, but white and everything else black.

If those images in the OP are the actual textures (Wow that’s low res) I could make it as an example if you’d like

Hmmm, I dunno… here is the whole VMT for the banshee, see if adding anything else helps.



"VertexlitGeneric"
{
	"$basetexture" "models/Halo/Covenant/Vehicles/Banshee/BansheeChassis_Diff"
	"$bumpmap" "models/Halo/Covenant/Vehicles/Banshee/BansheeChassis_Norm"
	"$nocull" "1"
	"$envmap" "env_cubemap"
	"$normalmapalphaenvmapmask" "1"
	"$blendtintbybasealpha" "1"
	//"$selfillum" "1"
	//"$selfillummask" "models/Halo/Covenant/Vehicles/Banshee/BansheeChassis_Emis"
	
	"$phong" 1
	"$phongboost" "3.75"
	"$phongexponent" "50"
	"$phongtint" "[1 .85 .85]"
	"$phongfresnelranges" "[.5 .85 30]"
	"$model" 1
	"$phongalbedotint" "1"

	"$rimlight" "1"
	"$rimlightexponent" "300"
	"$rimlightboost" "0.15"

	$color2 "[1 1 1]"
	$ambientocclusion 1
	"$detail" "models/Halo/Covenant/Vehicles/Banshee/BansheeChassis_Emis"
   	"$detailscale" "1"
   	"$detailblendfactor" "1.25"
   	"$detailblendmode" "5"
}


This is strange, the timer looks exactly like the fucked up Model viewer one when I open it in Gimp. Maybe this is contributing to the problem with it
http://uppix.net/8/3/c/720137bb4e7e62d29300cdc437c92.png

[editline]25th July 2011[/editline]

Actually, I don’t think that does say 12:00 on the normal texture. My bad eyesight plus a small texture lead me to falsely reading it. I did manage to get it to say 12:00 by messing with the Detail Blend

Edit 2
Well I tried whats been said on the TV remote from Duke Forever and its defiantly better since it doesn’t have any messed numbers but once again its only allowing the glow file to activate when I turn normals off

Here, try these: http://filesmelt.com/dl/Bubblegum.zip

The numbers where remade, so they might not look as authentic. Hopefully the glow will work though.

odd… I use Photoshop 7, so I don’t know anything about gimp V:v:V

Alright that works, thanks

I guess I can just do what you said before for any thing with a small glow on it

I’m still trying to see how to get it to work without editing it, like the TV remote. There’s no way in hell I want manually remove everything myself, I looked at the Cyber Ninja ragdolls from MK9 and they have the same detail VMT thing like Korro said. Now it works for me but only when I disable the normal

It’s fairly odd that it it pops up when you disable the normals to be honest. The VMT korro is giving you ought to work fine.

Uhm - one single thing - the black part of the microwave where the glow is - is it pure black x000000 black or not. if it is, try pushing it up in lightness a tiny bit. If I remember correctly, the details don’t work really well on full black areas.

http://uppix.net/0/c/d/1b4ff563a07ddf8dc5e6fdee8b6a4.png

Not sure whats up with it

Edit
I’ll stick with working on the remote instead, the microwave’s number is messed

Edit 2
Alright, I think I got it. I had to change the blend mode to 1