GM publisher error

Hi.
i’m uploading in Workshop a new addon… but what the error???

http://puu.sh/kDS1c/6f1eb96a97.png

1Gb total, 1023.9 Mb free… What wrong?

P.S. Code 8 - is “incorrect parameters”:

http://puu.sh/kDScG/ee4565dcff.png

I check all my addon files and addon.json - all OK.
What parameters wrong?

I’m getting the same issue. It’s happening on one addon in particular and I have no idea what this means. The rest of my addons will upload just fine but when I tried to do a reupload of one of my pre-existing addons, it failed with the number 8. Any help would be appreciated thanks!

try putting -addon first, -icon second
if u didint

The error comes from Steam, not from gmpublish.exe

Show us the .json maybe ( and compare it to one that works ).

While it’s uploading? That’s the only time I can see it

oh yea, addon.json:

http://puu.sh/kF6gC/5e9955b12c.png

Some mistakes?

Having the same issue :frowning: Ive also tried other programs that would upload to the gmod workshop an they all failed. They didnt give me any error codes, only a general “failed to upload the addon.” I used GAC (Garry’s Mod addon creator, gmpu 2.2 etc.) I also compressed my addon to a .gma different ways aswell, no luck. I give up :frown:

I really wish i knew what it meant by “incorrect parameters”. This honestly has never happened until now so IDK what’s going on either. I hope a solid answer comes through, because it’s been difficult to upload packs as of late so I feel a lot for you both DX

and @Robotboy what could Steam be doing that would prevent us from uploading and giving us that 8 number?

The upload error 8 is finally resolved! It doesnt mean the file size is too big or anything like that, it actually has to do with your folder properties. The way i did it was i went into the base addon folder (myaddon) and looked at its properties. I then went into the “Customize” tab and made it Music optimized. Then I also gave myself all permissions under the security tab. Lastly i went to the “General” tab, clicked on advanced and unchecked “folder is ready for archiving.” PS. Make sure all subfolders within the addon (lua, materials, etc.) are NOT Music optimized but are General optimized. I hope this helps! If you still have problems, put a comment on my profile!

Now I’m get error 9 - file not found xD.
What the f…?

Yeah this still didnt work for my case.

Wait on second thought nvm

22.11.2015 time 1:25
PLEASE HELP!!!
I’m start upload a new addon, and get THIS ERROR!

http://dl2.joxi.net/drive/0001/2487/108983/151121/5f2e632778.jpg

Error code 25(too much a good things) - Storage Quota limit? Or how many I can have publics in Workshop?

-now it does-

There appears to be a hardcoded ( and documented :v: ) limit in ISteamRemoteStorage for file uploads, that is 200MB total ( compressed ) and 100MB single chunk.

Now, GMPublish writes 1MB chunks, so I have no idea why it fails.

[editline]21st November 2015[/editline]

Try and see if you can get the compressed size to less than 100MB and see if that works.

Also, since I see those are Fake Factory models, keep in mind that any sort of nudity is not allowed on workshop.

Nudity not allowed, only original, adequate player models, NPC.
Earlier, I’m can upload max to 350Mb and excellent was compressed. But now…
Ok, I’m try check.

None of your uploaded addons exceed 200MB limit, 137MB is the largest one, which confirms the 200MB limit.

21:03 03.12.2015

I’m upload a new addon. Total size: 185 Mb.
gmpublisher compress it to 65 MB.
But I get a PublishWorkshopFile failed! (25) error again!
If 200Mb - limit, why I can’t upload? 185<200 …

http://puu.sh/lHKlm/accef61995.jpg

It’s not ok, help!