gm_chaparral

A small town in the Nevada desert.

http://cloud-4.steamusercontent.com/ugc/535141437556859141/11621195E2E360A18A8A37D3FD272B245337AE04/[/t]

I’ve been making this map consistently for about 8 months, so I hope you guys like it. It was largely because of Facepunch’s support, advice and criticism that I felt the need to keep improving and fixing every part of it - so thank you all.

Includes a large, detailed town, a massive underground bunker (thanks to Blueberry_pie), an airfield & airplane graveyard, tiny settlements scattered through the map, fully detailed interiors in almost every building, and much more.

[t]http://cloud-2.steamusercontent.com/ugc/535141437556865933/EB3A90EF66B567C4147D260E3753F6E2334DFBAB/[/t] [t]http://cloud-2.steamusercontent.com/ugc/535141437556873833/1FF2FBA8338F9630C4CDC021E7DAA54A7C379AAB/[/t]
[t]http://cloud-4.steamusercontent.com/ugc/535141437556867656/31BBAFBE4409A0BF560C7246A6BC94C9F8337609/[/t] [t]http://cloud-4.steamusercontent.com/ugc/535141437556872133/5E93B0C5BD61C1DB5796B85DDA22823B974A7918/[/t]
[t]http://cloud-4.steamusercontent.com/ugc/535141437556889047/1CA9BD32FFAC6A9D8644534A2F3515D2FCEAC2DA/[/t] [t]http://cloud-4.steamusercontent.com/ugc/535141437556890267/247BEB368B2F35CCF2B325E1FD277D0E72F4F806/[/t]
[t]http://cloud-4.steamusercontent.com/ugc/535141437556891546/4EEC25D7AE5C0C62040321C2064B5EE2B768D87F/[/t] [t]http://cloud-4.steamusercontent.com/ugc/535141437556892924/4C828B0A63003FA2E603ADFA564E6938919D30C4/[/t]

Download it here, and post in this thread if you have any bugs or criticism:

[t]http://cloud-4.steamusercontent.com/ugc/535141437556864711/41A5FCFEEF5EEF3CC54023BDBD42CA505B355F01/

Great map!

This looks fantastic, reminds me of the movie tremors for some reason.

can’t wait to give this a go. I’ll post any feedback or issues I find in a bit

Amazing job on the map, you put a lot of heart into it!

You released it! Squeal

I need to try this right now.

Sorry about that! I missed some custom content in the upload, but I just patched it. I hope so anyway.
If you’re missing any content in the map, please resubscribe to the Content collection. If that doesn’t fix it, then post a picture here, because that means I missed it :v:.

Reminds me of rp_cscdesert

Damn! This is an impressive map mate!

I see a hell of a lot more desert warfare in my future…

There wouldn’t happen to be a sfm variation of this would there?

Not familiar with SFM, but this map is compiled with HDR so I think it would work. Would I need to upload it to SFM’s workshop too?

Some L4D textures are missing even though I have L4D2 installed and mounted.

This might be more a problem with L4D2 lacking some of those textures for whatever reason (e.g. the walls in the billiard room screenshot are invisible, and I know that that texture is from L4D), and perhaps I may need to redownload the game or some shit like that. Is anyone else getting this problem?

https://dl.dropboxusercontent.com/u/100708596/2015-04-04_00001.jpg[/thumb]
[thumb]https://dl.dropboxusercontent.com/u/100708596/2015-04-04_00002.jpg

yep

That specific texture is definitely included in the content pack, I just cross-checked the lists. Are all of them installed?

LMAO! Download this too.

The ground kind of bothers me.

Well shit, it turns out that I forgot to subscribe to the last content pack. Thanks for the reminder.

alright so I’ve walked through essentially every building that I could find (probably still missed some) and am ready to show my initial findings for glitches and things.

first off there’s this weird white box type thing in the sky above the town. I’ve seen this issue before but i have no idea where it comes from.

http://i.imgur.com/uav4039.jpg[/t]

next thing I noticed was that this building seems to have an interior yet it is not enterable in any way that I could find?
[t]http://i.imgur.com/DRqAVBx.jpg[/t]

following that I had some real strange issues with floors in a few of the main town buildings. seems like a texture, cubemap, or some weird HDR issue? not sure which though
[t]http://i.imgur.com/Pcx7xUS.jpg[/t][t]http://i.imgur.com/TidCwj1.jpg[/t]

now onto the main issue I repeatedly had while roaming: invisible interior walls. it seems almost as if they had been a noclip texture but I highly doubt that would have been the case. I can only think it would be some weird texture issue or possibly something with how the content is split and is packed.
[t]http://i.imgur.com/FWlW7mA.jpg[/t][t]http://i.imgur.com/J2wpArk.jpg[/t]
[t]http://i.imgur.com/hKL0fX9.jpg[/t][t]http://i.imgur.com/3GRJx0t.jpg[/t]
even had it in the bunker
[t]http://i.imgur.com/l7mfHXZ.jpg[/t]

i have literally no idea why this issue is happening and/or if it’s something entirely on my end. hopefully you or someone else can shed some light on that.

otherwise I had missing door models in the government police/hospital type building, and some missing textures in the bunker:
[t]http://i.imgur.com/o2Vu6Nb.jpg

i’d like to point out too that I have all content mounted and also made sure to nab all the content packs released with this so that the map would work properly.

overall though I found the map to be pretty phenomenal with the amount of explorable space and enterable buildings, and the setting feels very familiar while also maintaining a lonely and slightly off-kilter feel to the entire desert. the motel is exceptionally creepy and discovering room 8 was pretty sweet. I did discover a fair few little references and easter eggs although I’m sure there are a ton more scattered throughout the massive landscape.
[sp]I especially loved the moon landing set[/sp] and I also discovered that [sp]that strange large black box under the terrain that teleports you to the crashed box marked with a 17, and could not for the life of me figure out if it was supposed to do anything or merely serve as a quirky object in the desert hinting at something else[/sp] if that was a reference though it totally went over my head I’m afraid.

anyways, really dig the work you put into this map and it surely pays off regardless of any graphical issues that may or may not just be weird happenings on my end. I’m sure this map will find itself quite heavily played in the months to come on rp servers, even though that’s not my thing personally. again though, great great work and love all the effort you put into this, can’t really stress that enough.

Looking towards the town drops my frames noticably, the cubemaps are broken (because of Workshop most likely), a few of the cacti and rocks are floating above the ground, and you should probably use vertex lighting on more of the props and set foliage like bushes to ignore normals, but other than that the map is absolutely gorgeous. Easily one of my new favourites, I love it. <3

Also, have you considered uploading to http://garrysmods.org/, too? They rebuilt the site and are improving it over the old one. You wouldn’t need to break it into multiple addons that way or need to deal with the oddities Workshop can cause (like broken cubemaps).

Thank you Violation so much, I love actual bugtesting like this over “ded map pls fix”.
It looks like you’re missing a little bit of everything at random. The bunker textures are default EP2, and would probably be mounted, and the invisible walls are actually just missing textures - but they’re packed/default L4D2, which seems to appear on other places in the room.
It could be that some games aren’t mounted correctly, and the content packs tried to install the rest? I’ll run it on a vanilla client tomorrow and see if I can replicate it. Thank you again though, this really does help me out.

As for the easter eggs, [sp]you can access the black box by other means. If you need a little hint - www.youtube.com/watch?v=hAAlDoAtV7Y . The teleport is to keep you from noclipping inside. And there’s one more easter egg you missed :v:. [/sp]

[editline]4th April 2015[/editline]

I tried to do as much optimizing as I could, but a version with areaportals pushed it way over 200% entdata, so I stuck with LODs and fades for the most part. Not sure what I can do about cubemaps, but I will think about reuploading to the new garrysmod.org, glad to see it’s finally up.

I am an idiot. Thank you kindly.