gm_oldforest

Hey, just getting finished my first map in hammer and i think its turning out pretty well :smile:

Im just here to post some pictures and you guys can help what to fix/add in the map. The map isnt very big, but its big enough for a first map.

http://img16.imageshack.us/img16/5260/hl22010060811500260.th.png
A part of the forest.

http://img443.imageshack.us/img443/206/hl22010060719035967.th.png
The lake.
http://img534.imageshack.us/img534/4007/hl22010060719041584.th.png

http://img576.imageshack.us/img576/8677/hl22010060811503870.th.png
Inside the cabin.

http://img37.imageshack.us/img37/5927/hl22010060811504876.th.png

http://img143.imageshack.us/img143/2802/hl22010060921083889.th.png
Attic.

http://img696.imageshack.us/img696/1503/hl22010061017050031.th.png
Outside the cabin.
http://img249.imageshack.us/img249/1944/hl22010061017053806.th.png

http://img813.imageshack.us/img813/5186/hl22010061114060067.th.png

http://img294.imageshack.us/img294/6720/hl22010061017171995.th.png
Comment!

Home > Garry’s Mod > Models / Skins

fuuu- CAN SOMEBODY MOVE THIS PLEASE :confused:

Ugh, now when this is in the right section… Comment!

Very good for a first map.

I think you should change the fog a bit. Maybe make the colour a bit darker and give it a max density. Make the “max density” keyvalue something like 0.65 or so, that should look better.
Also your displacements are a bit too blocky. Consider using more displacements or making those displacements have a higher displacement power if you can. 512x512 size displacements with power of 3 should work well. I also suggest using a blend texture for the ground.

Also the interiors seem a bit bland. Maybe add some trash on the floors? Trashdecal01a, trashdecal02a, trashdecal03a, trashdecal04a are all nice looking trash decals. Maybe also add some garbage props. Just pick prop_static, look for “garbage” and there is a nice selection of trash you can place on the floor. Just remember to disable shadows on those garbage props or otherwise they will cast an ugly shadow under them.

Also you should add a sprite on both of your lamps to make it look more like the lamps are the sources of the light. http://developer.valvesoftware.com/wiki/Env_sprite

Okay. I followed most of your rules and i added some more props in the cabin. Just a few questions…

  1. How i can add css props in if i didnt make the map for css? (or can i)

  2. Why the button i made moves when pressed? :3

  3. Can i make somehow shadows to the trees?

  1. Extract the CSS .gcf using Gcfscape into the game configuration you’re using’s main folder.

  2. There’s a flag on the button to disable movement on activation I think, if not a setting.

  3. Not sure try looking at the flags.

Okay thanks.

Updated the pictures in the OP.

tone down the brightness of the light.

move the light entity further away from the ceiling in the cabin.

Looks very good for a first map, nice job.

Thanks!

Which one?

Done.

The cabin’s ceiling shouldn’t just be flat, it should go up with the roof, unless you’re planning on adding some sort of attic. Because it doesn’t look real right now.

The roof should also come together instead of being flat like that.

both.
try 150 instead of 200.

OP should make it slightly slanted going up and meeting in the middle an then add support beams, well that’s my opinion.

Hm… In my opinion its good that way. Yeah, there could still be an attic…

yeah, it looks okay, just not very nice to look up and see a ceiling, with my idea it opens up opportunities for ragdoll posing.

Made the attic and some lightswitches, but ladders are still causing me some problems… I watched some tutorials and they all just say to make a ladder texture, but it doesnt work!
Oh and why my prop_static object keeps disappearing in the game?

Ladders

Some models cannot function as some prop types. Check the compile log for errors.

Okay, got it working but moar problems…
Some of the props doesnt show on the map in game and compile process window says this:


Error! To use model "models/props_foliage/rock_forest04.mdl"
      with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/props_foliage/rock_forest04.mdl"!
Error! To use model "models/props_foliage/rock_forest03.mdl"
      with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/props_foliage/rock_forest03.mdl"!
Error! To use model "models/props_foliage/rock_forest02.mdl"
      with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/props_foliage/rock_forest02.mdl"!
Error! To use model "models/map12_sawmill/logs.mdl"
      with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/map12_sawmill/logs.mdl"!
Error! To use model "models/props_mining/diesel_generator.mdl"
      with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/props_mining/diesel_generator.mdl"!

??

Edit:

Okay got it working. Uploading some new pics in a hour.