gm_save causes Lua errors (Somehow resolved)

I mentioned this earlier, but I thought i’d mention it again. Something is causing lua errors when making a save via the spawn menu or the gm_save console command.
This is what I’m getting:
[ERROR] lua/includes/modules/duplicator.lua:370: bad argument #1 to ‘pairs’ (table expected, got nil)

  1. pairs - [C]:-1
  2. CopyEntTable - lua/includes/modules/duplicator.lua:370
  3. Copy - lua/includes/modules/duplicator.lua:510
  4. CopyEnts - lua/includes/modules/duplicator.lua:541
  5. SaveMap - lua/includes/gmsave.lua:82
  6. unknown - gamemodes/sandbox/gamemode/save_load.lua:27
  7. unknown - lua/includes/modules/concommand.lua:69
    Is this a duplicator error, or is it an addon making this happen? If the second, then which one?
    UPDATE: It only works for non-stock Gmod maps for me.

It seems like its not recognizing the command gm_save. Have you tried doing the command gm_save in console? But other than that I dont know. Im not a code Junkie.

I have tried the console command, and the results are the same.
UPDATE: It seems to work perfectly fine so far.

How did you fix it? I’m still getting this error for the past week and a half and I’ve been getting no answers at all. Can you please tell me how you got it to work? I tried deleting my Gmod, re-installing, deleting addons - and it still persists.

It happened out of pure chance, that’s what I can say. Garry says that he’s resolved the issue, and it should be in the next patch.

Garry still has not fixed it, anyone got an ideas to stop gm_save working in console?

No.

Tell me what map are you using and how you call gm_save. It is most likely caused by an addon, so it would be helpful if you tell me what addons you use in your save.