GMCHOSTING ERROR

Hello I’m using a host called GMCHosting and when I use scripts from scriptfodder 80% of the time I will get a “Nil Value” error for example:

[ERROR] addons/sf4/lua/sf4/vgui/ship.lua:155: attempt to concatenate field ‘category’ (a nil value) 1. unknown - addons/sf4/lua/sf4/vgui/ship.lua:155

This is really strange because I’ve setup the server the same way with other hosts such as nitrous networks and I don’t get any nil value errors.

At one point I attempted to install an f4 menu that gave me errors like this:

[ERROR] addons/materialf4/lua/autorun/matf4.lua:289: attempt to call field ‘getCategories’ (a nil value)

  1. UpdateList - addons/materialf4/lua/autorun/matf4.lua:289
  2. MakeJobsTab - addons/materialf4/lua/autorun/matf4.lua:422
  3. OpenMenu - addons/materialf4/lua/autorun/matf4.lua:1068
  4. Call - addons/materialf4/lua/autorun/matf4.lua:1182
  5. unknown - gamemodes/darkrp/gamemode/modules/base/cl_gamemode_functions.lua:46

So I reinstalled the server installed the latest darkrp and added the f4 menu again with no other addons or modifications installed but I Still got the same error.

Any ideas?

Ask to author

Every F4 Menu does it.

The only reason why this would happen is if you had our DarkRP version installed from the addon manager which is quite outdated.

You will need to manually delete both the DarkRP game-mode and addon from your server and reupload the latest versions which will not give you the same error.