Gmod 13 HL2:EP2 Particles problem

Hello, I’ve been having problems on Gmod where Episode 2 particles arent showing up, specificly and only the particles of the portalbeam, but the clouds show up, and everything else is fine, just not those. Ive mounted EP2, EP1, and all other Half-life games, just those particles will not show up. Any help will be appreciated.
Also,
My errors are:


Attempting to create unknown particle system 'portal_lightning_03' 
Attempting to create unknown particle system 'portal_lightning_03' 
Attempting to create unknown particle system 'portal_lightning_02' 
Attempting to create unknown particle system 'portal_lightning_01_06a' 
Attempting to create unknown particle system 'skybox_cloud_glow2' 
Attempting to create unknown particle system 'skybox_cloud_glow3' 
Attempting to create unknown particle system 'skybox_cloud_glow' 
Attempting to create unknown particle system 'skybox_cloud_glow2' 
Attempting to create unknown particle system 'skybox_cloud_glow' 
Attempting to create unknown particle system 'Skybox_Smoke_03_06a' 
Attempting to create unknown particle system 'Skybox_Smoke_01' 
Attempting to create unknown particle system 'skybox_fire_01' 
Attempting to create unknown particle system 'skybox_fire_01' 
Attempting to create unknown particle system 'skybox_fire_01' 
Attempting to create unknown particle system 'Skybox_Smoke_01' 
Attempting to create unknown particle system 'Skybox_Smoke_01' 
Attempting to create unknown particle system 'Skybox_Smoke_01' 
Attempting to create unknown particle system 'Skybox_Smoke_01' 

Report it to the Gmod Beta subforums. Garry doesn’t look here often.