GMod 2015 Update corrupted Sandbox

So, after the last update, the game was working fine, until today.
My Skybox is black and it tries to derive entities with non-existant bases (which should exist, base_anim, weapon_base and stuff)
I remember this used to happened because of too many addons, however, my addon count is below 50 and my files are OK (checked the cache and reinstalled the game countless times, also tried it without any addon, the game still gave me the same errors).

Any temporary solutions or workarounds?
Thanks.


(User was banned for this post ("Help & Support" - Orkel))

Have you tried verifying your game?

Sure, just check the post above yours.

I have ran out of ideas on how to fix it.

Have you tried fresh installing GMod (removing the folder from common and reinstalling)?

Then uninstall all your addons, because one of them is doing this.

Also, please post in the correct place next time. This would probbably be best noticed in the help and support section.

Read his reply, buu…
It literally says he tried it without addons.

Apologies, I misread.

Backup all of your gmod folder and try a fresh reinstall. If the problem persists then it might be a graphics issue.

You may have a GPU driver issue. You may also have a hardware issue causing this…when was the last time you dusted your rig? Something may be overheating and causing Gmod to act all fucky. If it’s been more than a couple months since you dusted your computer perhaps just cleaning the heatsinks out will fix it, if not, perhaps reinstalling the video drivers and double checking that everything is still firmly seated in its slots?

Uhh. From the first post in the thread…

You may be onto something with the graphics problem, though. I’ve had bad GPU drivers do shit like this to me in other games. Never Gmod, but it has happened before, so it’s entirely possible Gmod could be warning the OP of bad drivers or something. I do remember from a few years back when I overclocked regularly that Gmod was pretty good at spotting an unstable CPU overclock by throwing very bizarre bugs out that had no real explanation, so it is sensitive to instability in the system running it.

Delete the sandbox folder from your gamemodes folder, then verify your game cache