Gmod acting like a pirated version? So much going wrong!

After many re-installs (and a couple of threads in this section) I’ve decided I need a proper thread that details the problems I’ve been having a bit more thoroughly in a bit to get some help.
From what I’ve heard I either have a Lua virus (fresh reinstalls disprove this theory) or a pirated version of Gmod (I can assure you I don’t. I’m an honest person that bought a limetless program at a small price).

Firstly, there’s the water. Lifeless, boring and brown:

Looks bad right? Wait till you see what it looks like underneath:

Right. That’s worse isn’t it? Thought so. Here’s a picture underwater, but looking up at the sun:

Water from the Orange Box engine seems to fail me as well it’s the same in Episode 2:

All water still has impact splashes.

There is also a huge problem with the option menu:

As you can see, the ‘Video’ menu appears behind the main ‘Options’ menu, the blue box being dragged down for selection. The selected video options themselves range from ‘Very High’ textures to ‘Simple Reflections’ on the water. Most are not on the the ‘Recommended for you system*’ settings and even if I select another and ‘Apply’, they stay on their original random settings. ie. I cannot change anything, even if I can see through the merged menus.

Source games I have (* means recently played):

Counter Strike: Source
Day of Defeat: Source
Half-life 2*
Hafl-life 2: Deathmatch
Half-life 2: Episode One*
Half-life 2: Episode 2*
Team Fortress 2*
Half-Life 2: Lost Coast*

Specs if you need them, but I haven’t had a problem before. All on high, good framerates:

Windows Vista 32bit
AMD Quadcore 2.2Ghz
Nvidea GeForce 8400

Current driver 181.22

Basically, why has any of this happened and what can be done about it? Many thanks to anyone that can help. These problems are really putting me off Gmod.

Update your video drivers and such.

I also had the reverse Z-buffer error (active windows in the menu are overlapped by inactive ones) but I can’t remember how I fixed it (either driver update or tweaking in the Nvidia control panel).

I’ve updated my drivers to what I though was the latest one (181.22). Unless there’a a newer version?


You couldn’t just tell me what your current settings are in the control panel. It’s a lot of typing, but I’d appreciate a comparison.

No idea. My previous card was fucking with me (it wouldn’t accept any but one driver) so I stopped updating some time ago.

I’ve seen nastier stuff: on one occasion, a map exit on one of the HL2 maps turned into a solid wall covered with a hall-of-mirrors effect. I swear, it should be invisible and nonsolid, yet the airboat bounced back with a “metal-impact” sound (before you start accusing, it’s NOT pirated).

Right click on Garry’s Mod in STEAM. Go to Properties -> Set Launch Options.

Type “-dxlevel 90” without the quotes.

Reboot the game

Don’t use DirectX below 8, or you will get EXACTLY this problem.

You better remove -dxlevel 70 from your startup parameter or even add -dxlevel 91 if your card is capable for DirextX 9.1.

Also - no need to keep telling us it’s not pirated, we believe you.

But yeah - Garry’s Mod DOES NOT SUPPORT DirectX 7.0.

Set the Launch Options as either “-dxlevel 90” or “-dxlevel 91”

I should not have made this picture, which gave you a time-advantage posting the solution :slight_smile:


I even wonder why he compared his problem with a “pirated GMod”. The “pirated” version does not even “malfunction” like that. Every version does! Because this is a Source-Engine bug with low DXLevel :slight_smile:

How do you know?

I only said it once, but I didn’t notice the dx 7 at the bottom. I’ll change it and see what happens.

It works again! Thanks guys! I wonder how or why it went to Dx 7 from 9?

Well, mine says it uses DX0.0 (WTF???)…