Gmod Cant Load HELP MEE!!!!

When I try To Load Gmod In singleplayer Its A Plain Grey Screen And After 5 seconds Its normal then All Until It say Initializing Game Data Then Shits Broken And I Have To End The Process to stop it
Pls help me
Any help will be appreciated.
EDIT:I Really need help!!!

[editline]29th June 2012[/editline]

Bump

Link to Steam account please. I’ve heard of people with this exact issue who did not own GMod, so I’d like to make sure.
Have you tried to do the verifying of integrity of game cache yet?

Yes and heres my steam

Post specs.

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1
Language: English (Regional Setting: English)
System Manufacturer: MICRO-STAR INTERNATIONAL CO.,LTD
System Model: MS-7512
BIOS: Default System BIOS
Processor: Intel® Core™2 Quad CPU Q9550 @ 2.83GHz (4 CPUs), ~2.8GHz
Card name: ATI Radeon HD 4800 Series
Manufacturer: Advanced Micro Devices, Inc.
Chip type: ATI display adapter (0x9440)
DAC type: Internal DAC(400MHz)

Weird.
Okay.
Try these commands and put them into your advance start up options (you can get there by hitting properties on gmod > set launch options)

Commands (try one at a time)
-dxlevel 81
-noborder
-window
-config

K trying it out ill tell you the outcome

[editline]29th June 2012[/editline]

It loads with -dxlevel 81 but the quality is crap

[editline]29th June 2012[/editline]

Any way to make -dxlevel 81 quality better?

Close this thred my gmod fixed it self

If anyone got this problem too , just rename addons folder to “Addens or anything you want” then try to restart game. if its fixed then try to remove all of your addons except wiremod and toybox. name of addons can destroy garry’s mod : Counter Strike Source Texture packs , Counter Strike Source Models Pack , Emporium.dll , Namechanger.dll . By counter strike source packs i mean the ones you downloaded from anywhere except steam. you can buy counter strike source $20 and don’t use fix packs anymore.