GMod closes itself immediately after starting

It’s rather irritating actually, because I click “Play”, the “preparing to launch Garry’s mod” window comes up and the screen resizes to accomodate for the game window (Or whatever it is it does), at this point I can see Garry’s Mod on the list of things open, then it closes.
It also has a habit of crashing Firefox. Anyways, necessary stuff:

System hardware specs

  • Intel® Celeron® CPU 2.40GHz
  • 1GB
  • Radeon 9250
  • Microsoft Windows XP Home Edition 2002 service pack 2

Addons

  • Adv Duplicator
  • BailOut
  • Buoyancy tool
  • CAF (Something to do with GCombat)
  • Colonies (NPC behaviour editor)
  • Counter-strike, (Which I don’t own, dunno why it’s there)
  • day-of-defear (Ditto)
  • Defult_sent_pack (No idea what this is)
  • Derma (Ditto)
  • DoctorWho (Models and NPCs)
  • Fin
  • GasSystems2 (Doesn’t work but I’m keeping it)
  • Gcombat08
  • hl2_ep2 (Same as Counter-strike)
  • Joystick
  • Ls3Core
  • LS3Entities
  • MiningAddon
  • no_collide_multi
  • Ol_measuringstick
  • Ol_stacker
  • PCMod2
  • PHX
  • Portal (Which I DO own :D)
  • propcannons
  • RD3 (Like lifesupport)
  • SB3 addon
  • Smart_Constraint
  • smartsnap
  • SpacebuildModelPack
  • Spacetechs Pet Mod
  • spidermod
  • Stargate
  • tf2
  • The Plague
  • toybox
  • WeightSTool
  • wire
  • wire model pack 1
  • zeno_clash

Yeah, it’s a looong list, I mean, most of them I don’t even use, and I got some entities and stuff from that library feature.

I haven’t played since 2 weeks ago, and there were no problems then.

Soo… any help?

:crossarms:

Also, PHX recently got added to GMod. You don’t need the addon anymore.

-autoconfig and -windowed to command line.

FF has alot of problems with crashing. Use Chrome.

The addon version of PHX has the tools, while vanilla GMod doesn’t.
But you can download the PHX tools on Garrysmod.org anyway.

Uuh… command line? You mean launch options?

[editline]6th February 2011[/editline]

Okay, I tried windowed and it just does the same, but with a window instead of the full screen.

Try renaming your garrysmod folder to garrysmodold or something like that then start up Garry’s Mod. See if that helps. (steam/steamapps/<steamname>/garrysmod)

Hmm… it looks like I’ll have to do that every time I start up GMod.
Is there a better way?

Do you keep putting your addons back?