Gmod crash on startup Engine error

It says Couldn’t load library gmod_audio (looking for interface IGMODaudio001)

Stuff I tried:

Completely exit Steam
Right-click on the shortcut which you use to launch Steam
Select “Run as Administrator”
From the Library section, right-click on Garry’s Mod and select Properties from the menu.
Select the Local Files tab and click the Verify integrity of game cache… button.
Steam will then verify the game’s files - this process may take several minutes.
Once the process is completed, the you will be notified of how many files failed the verification and will be reacquired.

Verify all Source games you have currently installed on Steam - this includes games like CS:S and TF2 if you have them, and some others.

If the game still doesn’t start, do a complete reinstall like this:
Un-Subscribe from all addons in the Steam Workshop
Right-click Garry’s Mod in your steam library
Select Delete Local Content
Go into your steam folder/SteamApps/common and delete the garrysmod folder
Re-install Garry’s Mod

Did this problem begin only now, or have you always had it (since the day you bought Gmod)?
Also, what beta branch are you on? We recommend “None”, you can select it like this: right-click Gmod, press properties -> Betas -> None

No one??

ok…