Gmod crashes every time I kill an NPC

Every time I kill any NPC, kill other players online, get killed by other players online, or get evaporated by an ar2 ball (or tron laser) then my game crashes. (hl2.exe is not responding) Does anyone know what I could do to fix this?

PC Specs?
Ram, GPU

HP Pavilon dv6000 Entertainment PC (Laptop)
Processor: Intel® Core™2 CPU T5300 @ 1.73GHz
RAM: 2038 MB
Intel Centrino Duo
Windows Vista

I hope that information is helpful.

This might not be it, but your PC Specs are not of the ones Gmod needs specifically, but it might be something else. Did you try re-installing, clearing it, and verifying cache?

What is your Video Card?

I’m not sure how to find what video card this laptop has.

Use speccy to show us our specs http://www.piriform.com/speccy

Here are all of my graphics stats


Monitor
	Name	Generic PnP Monitor on Mobile Intel 945GM/GU Express Chipset Family
	Current Resolution	1280x800 pixels
	Work Resolution	1280x770 pixels
	State	enabled, primary
	Monitor Width	1280
	Monitor Height	800
	Monitor BPP	32 bits per pixel
	Monitor Frequency	59 Hz
	Device	\\.\DISPLAY1\Monitor0
Mobile Intel(R) 945GM/GU Express Chipset Family
	Memory	224 MB
	Memory type	2
	Driver version	7.14.10.1214
Mobile Intel(R) 945GM/GU Express Chipset Family
	Memory type	2
	Driver version	7.14.10.1214


I’ve tried re-installing gmod
I’ve tried deleting the config.cfg
I’ve added -dxlevel 80 to the startup properties of gmod
But I’m still encountering this problem though. :stuck_out_tongue:

[del]You seem to be using a laptop.

GMod


**HATES**

laptops. [noparse]:frown:[/noparse]

Allow me to rephrase this…

You seem to be using integrated graphics.

Source


**HATES**

integrated graphics.[/del]

Gotta rephrase again… :rolleyes:

Your laptop seems to use Intel integrated graphics.

Source


**HATES**

Intel integrated graphics.

I run on a laptop and play just fine. The problem he has is that he is using integrated graphics from 2006 (945 is also used in netbooks from 2009). His laptop is quite dated, but it supports pixel shader but not vertex shader. If you ran without pixel shader at all (Pentium 4 and celeron chipsets from before 2006) you would BSOD if you just fired a weapon, and you would have colors flash everywhere. A possible solution would be to right click the game on steam, click advanced, launch options, and put in -dxlevel 80

(it’s -dxlevel 81)

Well 80 (or 81 - 85) did not work, BUT when I set it to 90 I was suprised.
The graphics are enhanced, including a never before seen light fog in construct. I was able to kill NPCS! There is an awkward shadow over the npcs though and I don’t know where that’s coming from.
http://img9.imageshack.us/img9/2540/gmconstruct0000fh.th.jpg
http://img7.imageshack.us/img7/3971/gmconstruct0001jh.th.jpg
Also when I spawn the tron laser on this direct x setting, weird glitch stuff shoots everywhere and the game crashes. I guess i can live with the npc shadows, and i can just avoid using the tron laser, but i’m wondering if this crash with the tron laser might lead to a larger problem with particle effects in general.
http://img717.imageshack.us/img717/4243/gmconstruct0003u.th.jpg
Whatever the problem is, if you guys have any suggestions i’ll gladly appreciate it. Thanks for the help so far!

Also I noticed this problem i’m experience appears to be exclusive to laptops with Windows Vista, as others have had this unsolved npc mystery as well.

Any laptop’s GPU is intergrated, since there isn’t space to put in another one.
I can also play fine, even with full graphics, and it’s a HP Pavilion dv9000, with nVidea GeForce GO 7600

It’s the Intel Integrated Graphics Cards that are the problem.