Gmod crashes on connect

Okay so when i try to connect to a server the game crashes to desktop with no error message and it’s really getting annoying. It doesn’t do it on ALL of them tough.

Any help plz? :frowning:

Go to your GMod root folder, are there any .mdmp files there?

Yep…a whole load of 'em.

Put your newest one there.

http://dumps.metastruct.uk.to/dumper.py?dump=hl2_130709_crash_2013_7_9T13_18_25C0.mdmp

Sorry, was gone on vacation.

Does this happen only on this server?

No, it happens on random servers, like yesterday I tried joining TnB’s stalker rp and it crashed, i tried singleplayer then joined the server, didn’t work, i joined another server then went to that one and same result. :expressionless:

Same happens to me, but my thread was forgotten about. Looking forward to a fix.

Here’s the latest one http://dumps.metastruct.uk.to/dumper.py?dump=hl2_130715_crash_2013_7_15T19_44_34C0.mdmp

This server was working fine until yesterday…now this is getting really annoying.

I am having the same issues, except mine is on a specific server. Mine has something to do with the steam workshop because that is the point where it crashes during the loading screen. It sucks because it’s my usual server :confused:

I KNOW HOW TO FIX. I just fixed mine, load Gmod. Go to options, go to multiplayer then put “Do Not Download Custom” or whatever it says. It fixes it, good luck.

It looks like Awesomium is crashing you, at least I think so.