Gmod Crashes on Launch

Crashes on the Blue screen with the word “loading…” in the bottom right

Things I have done:
restarted PC
verified game cache
reinstalled
I’ve uninstalled it via steam, went to steam dir, and deleted the GarrysMod folder, then restarted my PC, and installed it again via steam. and it still crashing…

there are no crash dumps, its a windows crash error


<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2015-10-09T00:22:17.000000000Z" /> 
  <EventRecordID>13532</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>Devin-Gaming-PC</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>hl2.exe</Data> 
  <Data>0.0.0.0</Data> 
  <Data>55ed7c2c</Data> 
  <Data>ntdll.dll</Data> 
  <Data>6.3.9600.17936</Data> 
  <Data>55a68dd1</Data> 
  <Data>c0000005</Data> 
  <Data>0004a6c8</Data> 
  <Data>13f4</Data> 
  <Data>01d102288c7412c8</Data> 
  <Data>A:\Steam\steamapps\common\GarrysMod\hl2.exe</Data> 
  <Data>C:\WINDOWS\SYSTEM32
tdll.dll</Data> 
  <Data>cbb5e2a3-6e1b-11e5-bec2-10bf4885e6f9</Data> 
  <Data /> 
  <Data /> 
  </EventData>
  </Event>

Computer Specs

http://puu.sh/kDkAl.png

A wise user once said, validate TF2

Was about to do this, but TF2 installed an update, and it launched correctly, it seems the last TF2 update messed up Gmod. Its working now. Thx