GMod crashes on start up.

Preparing to launch Garry’s mod, then it shows the gmod background loading and like 2 seconds later crashes to the desktop :confused:
i think it is like that since the last update…
saw a thread on SPUF with other peoples having the same problem… http://forums.steampowered.com/forums/showthread.php?t=1880501
but no answer

Any help please?

This “may” work:

  1. Reinstalling the game
  2. Deleting recent addonds
  3. Deleting “garrysmod” folder (steam/steamapps/yoursteamID/garrysmod/garrysmod)
  4. Downloading lastest nvidia/ati drivers
  5. Verify cache of gmod, (Right click, properties, local folders tab, verify cache)

Hey I have the same problem.
I have updated windows 7 and my nvidia card, still it does not load.
Tried all the steps above no luck there.
Tried other source games they work fine.
I get this error message.

     "setup file 'gameinfo.txt' dosen't exist in subdirectory 'hl2'.
          Check your -game parameter or VCONFIG setting."

It has worked before just recently stopped working.

didnt work here either…
still can’t play the game

Try adding -game garrysmod to your launch options

Tried doing that, it still doesent work

Post specs

Here is my specs

Intel Core i5 750 2.66Ghz
4GB DDR3 Memory
Windows 7 64 Bit, Fully up to date.
Nvidia GeForce GTX 550 Ti, Up to date
Bitdefender 2011

Harddrives Drive C 300GB ,Drive D 500 GB Both have over 200 GB of spare space

I am doing Internal Defrag on the source files to try and fix it

[editline]21st May 2011[/editline]

I have fixed my gmod for now I think bitdefender had something to do with it, I added all my source games to the games list in bitdefender and deleted gmod, creating the gmod files again and it works .