Gmod crashes on start.

Whenever I start up Gmod, it loads up to where it says “Facepunch Studios”

It comes up with this error.

http://www.deviantart.com/download/3354618739395402/well_piss_by_vgdcmario-d5jvsei.gif

It’s had this error since about 2 weeks ago, and then it worked, and now nothing works.

If it’s any help, it started again after a forced shutdown.

Have you tried reinstalling your Garry’s Mod?

Yes.

It scanned for game updates, validated itself, and crashed.

Bump (Sorry)

It stopped happening for a while, and it started doing it (crashing with the font error) again about a week ago.

Try verifying your game cache.

Tried that, didn’t do anything.

Try removing all your workshop addons

If you haven’t, you should uninstall Gmod from Steam, then go to your steamapps/[USERNAME]/garrysmod folder and delete it, just make sure you backup any custom settings files or what not before hand, then reinstall Garry’s Mod and try again. You probably had left over files from before the big 13 update causing issues.

Tried that, didn’t do anything (again).

Did you make sure you weren’t subscribed to any Workshop Addons?

You should also make sure there are no conflicting programs running and you should start up CSS, HL2, HL2EP1 and HL2EP2 so they can install the needed files that Garry’s Mod reads for you to be able to mount them in game if you haven’t already.

Yet another bump, [SUB]because I really want this fixed soon.[/SUB]

Tried those (At least C:SS and HL2EP2, as I don’t have HL2), didn’t do anything (yet again).

Trying Half Life 2 Episode One now, going to post results after I try and see if it will work.

This image may help, it shows the problem in the earlier version of Gmod. In the newer one (newer in terms of the Gmod 13 BETA that you had to get a key to use), it worked like a charm, save for the console at least.

http://www.deviantart.com/download/325131098/i_really_want_this_fixed_soon__by_vgdcmario-d5dkore.jpg[/thumb]

And even earlier; (Around 2 months ago)

[thumb]http://www.deviantart.com/download/313164173/affected_gmod_by_vgdcmario-d56g70t.jpg

I’ve tried moving my Gmod folder and reinstalling fully, but that doesn’t work either.

If it’s any help also, here’s a quoted text from the problem earlier.

I think I’ll try putting the FreeAgent Drive back in and hope it works (Now if only I could find it)
Here’s the thread link to where I got the quote from.

[SUB]Edited[/SUB]

Gmod 13 BETA still works like a charm on the Menu, save for the console text missing.

[SUB]**Edited
**[/SUB]
Can’t find the FreeAgent Drive. Gmod 13 BETA is not responding on loading a map (gm_construct) with several addons breaking.

If removing drives fixes your games, you have bigger problems than gmod. When was the last time you’ve reformatted your computer? Your registry files are probably all messed up, especially if you have “registry fixer” programs. Have you tried completely uninstalling/reinstalling steam?

Doing that now.

[SUB]Edited[/SUB]
Steam finished reinstalling, trying it now.

[SUB]Edited[/SUB]
Didn’t do anything. Going to try and reinstall Garry’s Mod entirely.

**[SUB]Edited

[/SUB]**Didn’t do anything

http://www.facepunch.com/fp/ratings/funny2.png

Also, this line of Console from the picture some posts above may help with this problem.

I think I may be missing a font.
[SUB]
Edited[/SUB]

Yep, I’m missing tahoma in Word, going to go install it.
[SUB]
Edited[/SUB]

Reinstalled it, the text on Facepunch changed.

[SUB]Edited[/SUB]

IT WORKS :rock: