Gmod crashes on startup

When i start gmod it brings me to the loading screen before the main menu for a split second and then crashes with the error message

Problem Event Name: APPCRASH
Application Name: hl2.exe
Application Version: 0.0.0.0
Application Timestamp: 54b92eb2
Fault Module Name: KERNEL32.DLL

Ofcourse that’s not the entire error message but it’s the important bits

Things i tried include

Verifying integrity of game cache 4 times
Fresh installing the game

Things i have not tried that could potentially fix???

Deleting KERNEL32.dll (Cant find it)
Removing all workshop addons and downloads (About 40GB of data would take me about 20-30 hours to download with my crappy internet)

So please somebody help me i need my daily dose of TTT and bhop or i will be sad :frowning:

Putting an image into this doesent seem to work so heres a link to it instead

Try disabling your addons, not removing them. Also kernal32.dll is a system file so don’t delete it.

How do i disable my addons when not in game?? Also i saw another guy having this same issue i think it has to do with windows 8.1

Try validating the game files of any and all source engine games that Garry’s Mod pulls content from. Especially TF2.

Thanks! That worked apparently i had 1 file missing from tf2… Last time i played tf2 was 1 and a half year ago so i think that i may have turned off my computer or something while tf2 was downloading an update