GMod crashes on startup

I get this error when I try to start gmod. I’m at the loading screen, and all the sudden I get the following error:

Anyone have any idea on how to fix this? I tried a full gmod cleanup.

This is happening to me, several of my friends, and several of their friends also.

It seems to be happening to everyone in one way or another. Did you get a random update and now its refusing to work?

I’m guessing we have to play the usual post-release waiting game.

Yea, same problem here.

I’m deleting all my games and everything and reinstalling them now. I’ll get back in the morning and hopefully it works.

This seems to be happening to everyone for sure, 18 of my friends opened friends and have been complaining on different chat boxes. (18 windows opened) so this isn’t scaled to a OS Vista/XP because it’s heppening everywhere.

I have XP so this problem is for everyone.

I have this problem, also.

Along with everyone who recently updated gmod. Randomly! :o

My Gmod crashes on start-up after a random update by “Steam” But I get this error Message…

The exception unknown software exception (0xc0000409) occurred in the application at location 0x12dbb428

please help, DATE CRASHED 6-11-08 TIME CRASHED 8:40.56

I may just be stating the obvious, but here it goes: if the crashing is happening on every OS, the OS isn’t the problem. Most likely, Garry got some 1s and 0s mixed up in the programing of the update.

Same here. :frowning:

:crying:

GMod didn’t get updated recently though? :raise: I think it was that TF2 update.

I’m not getting the error mentioned in the original post. I just see the loading screen (the blurred out version of the citadel courtyard) for 20-30 seconds, and then it crashes with a, “HL2.exe has stopped working” error. Is this the same issue, or do I have a separate problem to track down?

There are two issues that make me think something else might be up, either with Steam or my computer on the whole:

  1. I tried to merge a folder with my addons folder but the file transfer just got stuck and I would have to restart windows explorer. This was fixed after a restart but it made me fear for my hard drive.

  2. I tried to launch Half Life 2 when Gmod wasn’t acting right and got a “Platform Error: Module failed to initialize” error, but that was fixed by disabling the Steam Community ingame.

So, I don’t mean to hujack the thread, but perhaps could some other Vista people tell me if they’re having Gmod issues the same way I am, instead of that error? I just wish I’d checked the forums before deleting garrysmod and redownloading so many times.

I got it too (surprise surprise). Somebody broke something again… (Valve’s fault?)

Okay, so it’s good to know it’s not just me.

We’ll just have to wait for Garry to get a fix out.

Hey Alex. I am running on Vista and I get the same error. I haven’t tried Half-Life 2 yet, but I am getting the “stopped working.”

Yeah, a fresh reinstall doesn’t do anything. If you launched it and it randomly updated chances are you’re in the same bucket as the rest of us.

I am so glad I didn’t update yet… was too busy playing CSS.

doesn’t garry test the update before uploading it?

Edit:

doesn’t garry test the update before uploading it?