Gmod Crashes when loading singleplayer or multiplayer

So, here’s the issue. When I try to create a singleplayer world, the game begins to load as normal. However, right before it starts to give me control, it crashes. The same thing happens when I try to join a multiplayer server. I looked in the Garry’s Mod files and found something that I “think” is a crash report. I made a video of the crash as well. You might also want to know that I have “-dxlevel 81” and “-windowed” in my launch options. I ran dxdiag and made this file also. Is there anyone who can help?

Gonna give the same ol’ stuff everyone hears incase you haven’t already tried it. Do them in order and test if they work inbetween each
-Unsubscribe from every addon
-Go to garrysmod/addons/ and delete everything in it
-Update your graphics card
-Verify Game Cache
-Reinstall game

Is there any crash dumps in your Garry’s Mod folder?

Sadly, I cannot afford a new graphics card and these methods did not work. Thanx anyway!

[editline]25th May 2014[/editline]

click the word “something” in the original post.

By update my meant update your graphics card driver.

Oh. My graphics card is custom built which leaves behind some problems with that. Intel doesn’t release updates for my model.