GMod crashing after the recent update with reason 'EXCEPTION_ACCESS_VIOLATION_WRITE'

Sometimes I can go for longer than others whilst playing Gmod, but I keep getting crashes with the reason ‘EXCEPTION_ACCESS_VIOLATION_WRITE’
Can anyone make sense of this and relay back with a solution? Thanks.

Does this happen in single-player? Any addons installed?

Yeah, singleplayer, haven’t tried multiplayer since I rarely play it anymore. I have a plethora of addods installed.

Try disabling/removing them.

Is there any quick and easy methods to disable and re-enable all my addons at once?

My addons folder is 50gb in size and i’d imagine that’d take a while to back-up and move back afterwards.

There should be option in addons menu.

Yeah just saw it now, I must be stupid.

[editline]10th October 2016[/editline]

Tried my game without addons, and it seems to work fine.
Is there any way to diagnose which addon is causing this crash?

[editline]10th October 2016[/editline]

Strange. Re-enabled all my addons and now the game seems to be working fine.