Gmod crashing on startup - Engine error

Well hello there FP, I have a small problem. Gmod was working fine and dandy earlier today. Then I shut it down and get some dinner, and when I come back I try to start Gmod up, only to be greeted with a wonderful funderful engine error.

Now, before I started it up again I did install a map, zs_abstraction. So at first I thought it might have just been that. But then after I deleted the map and tried again I still got the error, so I don’t know. So if anyone on FP knows how I can fix this, It’d be much appreciated.

Did you Defrag and Verify via Steam?

I just checked and found that I do not have a “surfaceproperties_phx.txt”. Do you have Pheonix Models Pack? If so, did you get it via SVN?

Rename the garrysmod/garrysmod folder to garrysmodold then right-click Garry’s Mod in steam, select properties then local files and press the verify game cache button. It will re-download a fresh GMod installation.

I have same proble and tried redownloading gmod like darkness said, didnt work