Gmod Crashing without any Errors?

Well, here I was, playing Clockwork: Half Life 2 Roleplay. I had played it for a large portion of the day and was enjoying myself. I was in the middle of typing when suddenly my game lags a bit. I thought nothing of it until it took a few more seconds than a usual lag and the usual voice lag stops. From there my game is closed, just poof. No error message, no alert sound, nothing. So I start it again, furious of what just happened, scolding at my computer for some god-known reason, as if it could hear me. So, it works well for a minute or two after starting the server and it happens again. Furious and just welled up with anger, I try to connect one more time, and this time, it gets only to the point where it is “Initializing Clockwork Files” on the clockwork menu, from there if closes again. I restarted my computer, uninstalled my recent addons, even reinstalled Gmod, but nothing worked.

I looked up everything I could, nothing worked, though some did have a similar problem, one even had a problem with CW: HL2RP like me, but none of it helped. I checked Norton to see if that was the source of the problem, as Norton tends to just close problem programs sometimes, and the only thing it says was that hl2.exe was using a lot of data, but never said anything about closing it. All I want to do is have my game back.

my computer specs:

OS: Windows Vista Home Premium (6.0, build 6002)
Processor: AMD Athlon™ 7550 Dual-Core Processor (2 CPUs), ~2.5GHz
Memory: 3070MB RAM
Videocard: NVIDIA Geforce 6800 (1528MB memory)

I know it’s not my specs because I’ve been using this computer for 2 years now.

[editline]6th July 2014[/editline]

Here’s the Dump File:

http://dumps.metastruct.uk.to/dumper.py?dump=assert_hl2.exe_20140705183924_1.dmp&key=o_2CfWKjrnog8OZN5BY2aWMD-IZAinr5206_ZTwPiWNYNAgy8eHr0ARSiJnluzcM10I7HFpEQ5FFRd5mHL6sWTsLpLXxNVXJeyaeHF-5YB27TNir7gl7D3GstLX0_obWnvFhrnu066Nz6lCYfgOYPi3xDQRy76f_vVNR9MRqO74=