Gmod Crashing

Hello, im writing this because ,as alot of other people, Im experiencing this weird crash after the last update of GMOD.
It says: “[Steam] SteamApps() Is NULL” just after the startup where shows the background and the loading bar.

Some users suggested around to post it on facepunch since it wont get fixed if no one posts that and I came here to write it.

Steam Users Forums threads:

EDIT: Sorry for the wrong section, I havent seen the “Help & Support” section.

I also have this problem now, didn’t have it 2-3 days ago

Dude, It’s when you’re using PIRATED VALVE Stuff on steam !!!

I own Valve Complete Pack and i don’t have pirated Steam games. I haven’t downloaded/installed anything in steam in the last days and GMod worked for me 3 days ago. However, GMOD 13 beta does work for me

Pirated? I own this game on Steam. I was playing GMod perfectly yesterday on Spacebuild Omen V2 and now today I can’t launch it. You want proof this isn’t pirated? Look at my Steam account, I own it. Garry’s has broken GMod probably, and he might/should fix it in the next few days.

I have a simple solution. It worked for me, and I hope it will work for you.

First, quit Steam. Make sure that the process isn’t running after you quit.
Then, restart Steam.

Like I said, it worked for me, but I** cannot** promise that you’ll get the same result.

Restarting steam actually worked for me :D, thanks

Well fuck, thats great. Whenever i try to launch a game, this damned “Searching for game updates” pops up, and i have to wait, a real long time to launch the game, i have waited about 15 mins now, help anybody?

I may have a fix for those of you using an antivirus program called “Avast”.

  1. Before Gmod was broken, try to remember if you saw an Avast alert pop-up when you opened Gmod.
  2. Check in your Virus Chest for a file called: “vstdlib_s.dll”.
  3. Restore the file and turn off your File-Shield.
  4. Open Gmod.
  5. Restart Steam
  6. … Reply and tell me if it worked.
    Remember, this MIGHT only apply to users that use Avast, it worked for me, but might not work for you.
    :eng101:

Thanks You !! Naska This is working !!

Thanks for the reply Heyob! Oh, and an added note on my previous post, you’re going to want to keep the file-shield off while playing Gmod, or it will move the file again. You may need to wait until Avast fixes it. I reported it as a false positive, so it might be fixed in a Virus Definitions update.

the problem ive been havin is the game wont start at all it says somthin about it exeeding the blob???

If all of you are having this problem that means that there was a small break in the code, Chill out and wait for an update to fix it.

EVERYONE! I FOUND HOW TO FIX IT!
1.Opt out of the Steam Beta Update.
2.Restart Steam as it asks you.
3.???
4.Profit!

sorry for posting on this old thread, but i had the same problem, until i removed Iobit Malaware Fighter
If you get it to work, before joining any server, enter “vgui_allowhtml 0” in the console.
now the game works!