Gmod Dedicated Server invaid CD key?

So ive updated my HLDSUpdatetool to the new Steam pipe using SteamCMD (actually i just did a full reinstall of the server so none of the old files exist)

Everything went fine but when i try to Connect to my server (currently testing on LAN for now) it wont show up in the LAN Server directory, so i then tried to connect with console by doing Connect โ€œIPโ€ Alas i get this message. So what has gone wrong ? :frowning:

I followed everything step by step according to this http://wiki.garrysmod.com/page/Hosting_A_Dedicated_Server

Bump of Death, I need this to work so i can start working on my Game mode :frowning:

are you running the server and gmod on the same pc? i believe thats what causes it, they must be on separate pcs

Yes, but that was never an issue before. Now that ive updated to SteamCMD i cant connect :frowning:

Iโ€™m sorry, but thatโ€™s bullshit. I used to host a server on my desktop, and I was able to start my game, go into the console, type:


connect 127.0.0.1

I had zero problems. I could even play with my friends connected from their homes.

Have you tried putting it online just to make sure the LAN is the issue?

the LAN works fine in Gmod, even a server hosted with hamachi. But for some reason the files i got from SteamCMD (Doing what Garry told us) were invalid, or had an invalid CD key

[editline]25th June 2013[/editline]

EDIT: Gave up and reinstalled the entire server. Works now.