Gmod Dedicated Server's FastDL Not Working

Before I get into the details, I’m using my PC as the dedicated server (to test things before buying a dedicated server). Also if you do give some helpful info, please be semi-detailed about it to help me out, I’m not the greatest at this stuff but I’m trying (:

Problem: When connecting to my dedicated server, fastdl does not kick in and nothing gets downloaded by anyone joining (have had myself and 2 other buddies test this).

Before you spout out tons of things to check I’ll just give you a list:
—I’ve followed ALL of these sites, doing all of this from scratch each time:
http://xuras.net/index.php/topic,1037.0.html

as well as checking numerous forums.
—The ports on my PC ARE open and done correctly.
—Here’s my server.cfg and I KNOW that using addons folder wont work, at least according to most of the places I’ve checked. There are files in http://azchick.com/sirbob77/garrysmod/models/player/Group03m/ that should fastdl and tell me that fastdl is working (but doesn’t).
[lua] hostname “pizza partyz”
sv_defaultgamemode “DarkRP”
sv_lan “0”
maxplayers “20”
sbox_allownpcs “0”
sbox_maxprops “175”
sbox_maxragdolls “0”
sbox_maxnpcs “1”
sbox_maxballoons “10”
sbox_maxeffects “1”
sbox_maxdynamite “2”
sbox_maxlamps “5”
sbox_maxthrusters “25”
sbox_maxwheels “20”
sbox_godmode “0”
sbox_plpldamage “0”
sbox_playergod “0”
sbox_noclip “1”
sbox_maxhoverballs “25”
sbox_maxvehicles “1”
sbox_maxbuttons “15”
rcon_password “guess”
sv_downloadurl “http://azchick.com/sirbob77/garrysmod/
sv_allowupload “1”
sv_allowdownload “1”
[/lua]
—The file permissions on my FTP site are setup correctly (775, i’ve also tried 770 but still nothing).

I’m not sure what to even try anymore because as far as I know, everything should just work, but fastdl doesn’t. ANY help would be appreciated.

bump…

bump…come on, someone give me a hand

Well first off the webadress should show something like this game02.tuska.us/download/garrysmod/ as you can see it shows the dir’s but i too cant get fastdl to work