gmod directx11 problem PLEASE HELP!

i am having a problem with gmod when i launch it it says i need to update my directx but it takes me to the microsoft website and downloads the installer then it installs but while its installing it says i have the latest directx so i think its garrysmod that has an outdated directx but idk please help me fix this

[editline]22nd September 2014[/editline]

well if anyone knows how to fix it reply to this post and i will get back as soon as possible

have you tried using directx 9?

-dxlevel 90 in your launch options

i just did that now and it still does the same i put it in my launch options

http://support.facepunchstudios.com/kb/articles/26-your-directx-runtime-is-out-of-date