Gmod error with css addons

I am trying to use the CSS realistic weapons addon V4.0 to load darkRP custom jobs on my darkRP server, but when i try to load my server i get this in the gmod console:
(It then instantly drops me from the server after …loading client)
(Also I have checked the files are all present)

Couldn’t include file ‘darkrp\gamemode\cl_init.lua’ (File not found) (<nowhere>)
Couldn’t Load Init Script: ‘darkrp/gamemode/cl_init.lua’

[ERROR] addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_base/shared.lua:444: ‘)’ expected near ‘|’

  1. unknown - addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_base/shared.lua:0

[ERROR] addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_base_snip/shared.lua:438: ‘)’ expected near ‘|’

  1. unknown - addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_base_snip/shared.lua:0

[ERROR] addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_famas/shared.lua:177: ‘)’ expected near ‘|’

  1. unknown - addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_famas/shared.lua:0

[ERROR] addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_glock18/shared.lua:166: ‘)’ expected near ‘|’

  1. unknown - addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_glock18/shared.lua:0

[ERROR] addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_knife/shared.lua:51: bad argument #2 to ‘CreateFont’ (table expected, got number)

  1. CreateFont - [C]:-1
  2. unknown - addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_knife/shared.lua:51

[ERROR] addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_pumpshotgun/shared.lua:282: ‘)’ expected near ‘|’

  1. unknown - addons/css realistic weapons 4.0 (admin only)/lua/weapons/weapon_real_cs_pumpshotgun/shared.lua:0

Thanks for any help and responses in advance

Can you show me your Shared.lua? I think you may of messed something up, MAJORLY.

(Just post a few lines of it will work).

Thanks for the reply - but I solved this by using a different darkrp gamemode that did not require CS:S Realistic Weapons. But thank you anyway :slight_smile: