Gmod Fails to launch

Ok, I just got windows seven; I reinstalled steam and garrysmod.
Any steam game I try to launch, I see the game on the tab at the bottom with the game I try to play; then it goes away in like .5 seconds. (Please Help Me)

ram- 4gb
processor- Intel Centrino 2
Graphics card- Nvidia
Operating system- Windows 7

Try this:

1: Open Steam, right click on GMod, and click “Properties”
2: Click on “Set launch options”, in the box that pops up, type in “-fullscreen” (Without the quotes, of course)
3: Hit okay, and launch GMod

Yeah, its not that it dosen’t show up. It comes up then exits. hence you see nothing.

Make sure your GPU drivers are up to date. and go on steam, right click gmod, properties, local files, then verify game cache

Just wondering, did you try what I posted, or are you just saying that you’re “sure” it won’t work?

Oh I tried, I first found that out on youtube.

What Nvidia card are you using? Also, dumb question, but how long do you wait after the startup window disappears? It can often take a while.

Really helpful.

Problem solved