Gmod Fails to run on CentOS While using Server.so Glibc 2.5

I did look over one thread i saw , and used the server.so it worked so much untill server loadup .

But when someone joins the server i get this . Tried vphysics.so fix i found on google but it did not work.

Any suggestiosn what could be the issue ? The Debug has nothing more also.

Also somehow the server loaded up also without 2.7 gblibc but it still gave me that error when connecting or
“Sending Client Info”




Client "CreepyMoto#!" connected (91.152.171.20:27005).
PreMinidumpCallback: updating dump comment
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20111110082616_1.dmp
success = yes
response:  CrashID=bp-96e474d4-c037-4089-b985-fe7122111110

Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Thu Nov 10 08:26:20 EST 2011: Server restart in 10 seconds


http://dumps.garrysmod.com/

Upload the dump file there.

Hard time finding the .DMP file. It should be in /tmp/dump/ but theres not even that folder.

Might try to make one. Tmp folder is in ~ , should it be in srcds folder ?

EDIT : Never mind it was on root access location . Had to ask hoster.

http://dumps.garrysmod.com/?view=665911147&refresh=1

It should be in the root folder.

Yeah Edited my post.

http://dumps.garrysmod.com/?view=665911147&refresh=1

Another dump but kinda same info

http://dumps.garrysmod.com/?view=1536080474

I got no idea, seems more of an internal error. Your running CentOS right? If so I strongly recommend debian or ubuntu.

half year ago with other Centos it worked and had no porblems what so ever.

Valve updated the dependencies a few months ago, and CentOS 5 doesn’t have them.

God damnit . Guess i have to wait till September to try out debian or Ubuntu. Centos for me gave this feeling of simple and easy. Tho it doesn’t have updated stuff much which is sad.

Why do you have to wait?

And don’t worry about ubuntu. If you are planning to only install srcds shit, the only dependency you require is lib32gcc1. Everything else is as straightforward as CentOS.

Its just im using someone else VPS at the moment.

Well for example , wasn’t ubuntu download cmd different ? Centos has Yum and ubuntu had abt-get if im right.

That’s the only real noticeable difference. I find them extremely similar, you get used to apt-get very quickly.