GMod FastDL not working

Alright I’ve set up a GMod server through srcds

This is my start batch file


@echo off
cd C:\Program Files (x86)\Valve\HLServer\games\orangebox
echo Starting game server.
echo Beginning "Garry's Mod"
srcds.exe -console -game garrysmod -port 27015 +map gm_construct +maxplayers 16
echo "Garry's Mod" has now started.
echo It is recommended that you start Server Crash Recovery aswell.

This is my server.cfg


hostname GMod constructing server
rcon_password faggot
sv_password 
sv_lan 0
sv_allowupload 0
sv_allowdownload 0
sbox_noclip 1
sbox_godmode 0
sbox_weapons 1
sbox_plpldamage 1
sbox_maxprops 300
sbox_maxragdolls 5
sbox_maxnpcs 0
sbox_maxballoons 25
sbox_maxeffects 5
sbox_maxdynamite 15
sbox_maxlamps 10
sbox_maxthrusters 20
sbox_maxwheels 40
sbox_maxhoverballs 20
sbox_maxvehicles 5
sbox_maxbuttons 20
sbox_maxemitters 0
sbox_maxspawners 0
sbox_maxturrets 4
net_maxfilesize 64
cl_allowdownload 1
cl_downloadfilter all
download_debug 0
sv_downloadurl http://gmodjasonfun.x10.mx/Garrysmod
sv_allowdownload 1
sv_allowupload 1


if i enter that url in my browser it goes 404
but if i do
ftp://gmodjasonfun.x10.mx/Garrysmod
it shows all the files ive put on there and what not, so im sure the file host is working.
I know fastdl isnt working because I’ve tried different things to check whether its working (LOTS OF SHIT, I know for sure its not downloading from filehost)
It always downloads from the server (srcds) not the fastdl.
When i start the server
despite my server.cfg being setup
sv_downloadurl is always set as “”
I change it to that http url, but it still downloads from the server, and not from the filehost(x10)
what do i do?.. somebody help me please.

[editline]1st July 2012[/editline]

Shit wrong place sorry

I would think its because you are trying to use ftp, when I just tryed it, asked me for a username and password (due to ftp), as far as i know, FastDL needs a straight through file server http with no passwords, gmod simply sends the client to that address to get the files needed.

alright fixed the server so now it works directly from http,
but everytime i start server, sv_downloadurl is set to “”
how do i fix this?

Add sv_download to console line autoexec