Gmod fps drops, alot of them.

spec:

Manufacturer:
System manufacturer
Processor:
AMD Athlon™ 64 X2 Dual Core Processor 6000+, MMX, 3DNow (2 CPUs), ~3.0GHz
Memory:
3008MB RAM
Hard Drive:
157 GB
Video Card:
NVIDIA GeForce 8800 GT
Monitor:
Plug and Play-skærm
Sound Card:
Realtek HD Audio output
Speakers/Headphones:
I have
Keyboard:
USB-rodhub
Mouse:
USB-rodhub
Mouse Surface:
Operating System:
Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.090206-1234)

Sometimes the game freezez just in the middle of everything for a few seconds and comes back again.

When i join a server (normally with alot of people) it freezez for like 20 seconds (when im inside) and then i lag alot. After 1 minute of gameplay it’s normal but then i got small freezez

Any ideas?

Just wanted to add: I go from 70 > 5 fps for like 4 secs

Well you should know that:
PROPS= LESS FPS MORE PING
PLAYERS= LESS FPS MORE PING
VEHICLES= LESS FPS MORE PING
Animated Materials…
Large addons…
Large Maps…
So on and so on…

You should know you’re dumb.

Yes, 70 is greater than 5.

He used it as an arrow. “Seventy to five”

/sarcasm/

Ow thanks for the help guys! You’re just so awesome /sarcasm/

Ow, i’ve been asking on 20 servers and NO ONE knows the answer. cool

It’s because of too much crappy lua, creating garbage. Everytime you have these lags, the garbage collector is “collecting the garbage”. And this causes massive FPS drops.

Read more about this issue here:

Here is the thread about it and with a solution: http://www.facepunch.com/showthread.php?p=13509200#post13509200

Well I don’t believe any of you are correct. I have had the same situation, literally the exact same problem, in Left 4 Dead. Try aVoN’s solution as for mine will cost money. My problem was with my Penom II X4 overheating. Even in simple games it was getting way to warm with the cpu cooler it came with. I had to go to my local best buy and purchase a ThermalTake cooling system.