Gmod FPS lag while Skyrim = high

Hello gentlemen.

I just bought a new laptop, and I can run games like CSGO and Skyrim on high with 60fps.
But for some reason I cant play simple gamemodes on Gmod like TTT with more than 30 fps.

The specs of my laptop are:

Nvidia GeForce GTX 765M 2GB
Intel I7-4700MQ 2.4Ghz (3.4 Ghz boost) Quad (4th gen. Haswell)
8GB 1600Mhz RAM
SSD drive
1080p screen

Can anyone explain why I cant get Gmod to run with more than 30 fps?

What i have tried so far:

  • Disableing all addons
  • Deleting the config
  • Disableing vsync
  • Different graphics setting (high to low) (It should run fine on high though)
  • Making sure that the dedicated ideo card is running, and not the IntelHD card.

Any help is very welcome :slight_smile:

Currently the game only runs on one core regardless of your multicore setting in the options. Garry said it will be enabled again soon after some crashing issues are fixed.

Is it exactly 30 frames per second? If yes, then the game has a frame rate limit.

Did he disable multicore rendereing recently? I can remember the game running smoother on my older laptop a while ago.

No it varies. But 30 is max on high settings.

As others have said, this is most likely due to Gmod’s multicore rendering having been broken for over a year now

Shouldnt 3.4 Ghz be enough anyways?

Frequency is never a good indicator of the performance that a CPU will give you.

Now that I did yet another round of googleing, I see that many people are struggeling with this. Buying high end PC’s only to get 30 fps from Gmod.

And regarding the CPU, the i7-4700MQ is more or less the mid++ budget gaming laptop standard right now, so I im quite confident in it.

My friend next to me has a 2 year old laptop, with a AMD 4600M cpu, and he is getting 60fps. This is getting ridiculous

It’s a problem with NVidia Optimus. It’s shit all to do with multicore rendering.

I mentioned this a while back, no reply from any FP staff.

You will probably get better FPS if you set GMod to run on the Intel card in the NVidia Control Panel.

Thanks for sharing your knowledge!

Is there no way to make the Nvidia card work with gmod? Or some settings to make a profile for hl2.exe in the Nvidia control panel?

I disagree; intel cards many times have issues with Garry’s mod.

Given that the same problem (only less severe but still noticeable) is observable in TF2, I’d presume that it is a problem with the particular branch of source that TF2 and GMod use, so unless Garry either puts a significant amount of time into investigating and fixing this issue (won’t happen) or Garry moves to an newer branch of source (won’t happen) this problem will always exist.

As I said, your best bet is to run the game on the Intel card.
There isn’t really any fix I’ve been able to come up with.

[editline]14th October 2013[/editline]

Anything HD 4000 and above should have no issues. I get higher FPS on my HD4000 than my 780 running through Optimus.

Well i did in fact get better fps with the Intel chip, but its like 40 fps, and drops to 5 fps at random times.

If you go into the advanced power plan settings in windows you should be able to change the intel card’s power management settings from balanced to high performance and that may stop the random 5fps spats.

Ok I’ll try that.

To be honest, im still not quite sure what the problem actually is.

So it related to the Nvidia card. Is the problem that its not handeling single core rendering in Gmod?

As I said, it’s not a probem with no multi core. The same problem existed way back before it was disabled.

Optimus just seems to disagree with the branch of source. I couldn’t begin to pinpoint the actual cause of the problem.

Did you try running the laptop from the 765M? I mean in the BIOS there should be some setting to use the dedicated only with no Optimus at all. Not just from software. Unless if you’ve tried that already, did it start happening after updating the GPU driver at all?

Have not tried this yet. Will do

Any news?

Cant find any options for disableing the IntelHD chip in BIOS :confused: