Gmod Freezes on start.

When I start Gmod it freezes with an Image of the loading screen and does nothing else. I Have a NVIDIA GeForce 9400M Graphics Card with the newest update. I’m running Windows 7 64-bit on a mac with Bootcamp. My Processor is an Intel Core 2 Duo. Please Help.
~Friendsxix
EDIT: I have 4GB of Ram as well.
EDIT2: My Addons folder is empty.
EDIT3: My computer was wiped recently. Before the wipe Gmod worked Perfectly.

well u have a way better comp than me and i can run it when it goes to the running screen how long do you let it sit there the first time i did it i let it sit there for 5 minutes and it was fine it just took awhile to startup the first time

I’ve let it sit for 20 minutes…

ok then try then go to steam then right click garry’s mod and go to properties then click launch options then type in “-dxlevel 81” w/o the " marks then try it

Still Doesn’t work :expressionless:

Delete the garrysmod folder in Steamapps<Your Steam Name>
then run it with the -safe launch option

When I tried that the window Stops responding :expressionless:

Are any of the other source games working at the moment or are they crashing too?

All other Source Games work Fine (TF2, Portal and HL2.)
EDIT: Haven’t tried HL2 in awhile, I’ll try it again.
EDIT2: It needs to Validate the HL2 Files. If they were damaged would it screw up Gmod?

[editline]06:03PM[/editline]

Well HL2 isn’t the Problem. Deleting it Still makes Gmod crash.

EDIT
Now it Works after HL2 is Gone :smiley: (Took a Little long to start…)
~Friendsxix

So it was Half Life 2 all along.

Hopefully gmod will work whenever you reinstall it.