Gmod gamemode error

ok i dont know the exact error so i will try to explain. i host a 100 slot gmod server off of my pc but it wont let me run any gamemode other than sandbox i tried loading darkrp and when me and my friends joined it kicked us for lua errors so i did sv_kickerrornum 0 so then we could join but once we got in the menu’s wouldnt open we had black physguns and all the sandbox weapons. same thing happens with the stronghold gamemode. Is there any way to fix this? if so please help me out!

[editline]5th February 2013[/editline]

i know the gamemodes work because i run the exact same files on my hosted servers and it gives me no trouble.

Is this a dedicated server?

Is there any reason for hosting it off your PC and not your rented server? Players will have better connection to the rented server and it may even be against your ISP’s terms of service to host a gameserver.

the reason i am hosting it off my pc is so i dont have to pay for yet another server :confused:

[editline]6th February 2013[/editline]

i am running a gaming community and cant afford to have more than 3 hosted at once.

[editline]6th February 2013[/editline]

i also did the one thing to make the server stand alone if that helps. also when i open the server from ingame like the start single player thing the dark rp works but from the stand alone launcher it does not :confused:

Why not just get a dedicated box, and run your own server (you can run more than one gmod server on a box)

wouldnt i have the same issue? the pc i am running the server on is a custom built home server and has no problem running it. The issue i am having is running a gamemode other than sandbox.

[editline]6th February 2013[/editline]

also i am not sure by what u mean by a “Box”

https://www.nfoservers.com/order-virtual-dedicated-server.php <–
That is what i’m talking about a “box”

Do you have CSS installed when you run DarkR or TTT since they both need it?