Gmod & Gmod 13 not starting.

Hello everyone, one of my first times here on the forum.

I bought today Gmod through steam, signed for the beta and downloaded the gmod 13 beta. Now, I have a fresh steam installation, with both games and both don’t work.
Whenever I start Gmod 13 Beta I get the following message on the loading screen “No Steam API. Try restarting Steam.”
And if I try to play the normal Gmod, I get this error “[Steam] SteamApps() Is NULL”.

I don’t have any pirated games on steam, just my new copies of Gmod. I already tried restarting both the machine and Steam unsuccesfully.

My specs: Windows 7 x64 SP1, Q6600 2.4ghz, 4gb Ram, ATI HD4870.

Thanks very much for taking the time to read my problem with the game, thanks.
Web.

If it helps to figure out this problem, I uninstalled both games and now installed ONLY Gmod. When I try to launch it, I get the exact same error as described on the first post. :confused:

Do you have a link to your steam account?

In most cases in something like this, it’s because the op has pirated gmod.

I’m sorry but I’m still new to Steam. Where do I find a link to my steam account? Is it my profile? In that case, i suppose the link is this one:

Have you tried restarting steam?

After a little bit of research, I’ve come to the conclusion that I have no idea what could be causing this. Pretty much every other instance of this problem was caused by either 1) A bad update affecting Mac users, or 2) pirating the game; neither of which apply here.

However, running through the standard procedure for dealing with GMod problems may be what you’re looking for.

Try these in order.

  1. Restart Steam (done)
  2. Restart computer (done)
  3. Delete clientregistry.blob
  4. Verify integrity of game cache: Open up Steam, right click Garry’s Mod, hit Properties, click Local Files tab (However, seeing as you have a clean install, this probably won’t solve any problems but it’s worth trying)
  5. Clean GMod. (Once again, clean install, probably won’t help but worth trying.)
  6. Reinstall Steam
  7. Reinstall Garry’s Mod

Also of mention, I’ve seen a few threads suggesting the being a part of a Steam beta may cause some problems as well. If this is the case with you, then opt out (You have to opt in to Steam betas, so if you don’t know what I’m talking about just ignore it.)

[editline]22nd July 2012[/editline]

Oh come on at least read his entire post if you’re trying to help him.

Guess that’s what I get for trying to post when I haven’t slept in forever

DeathDoom, thank you VERY much for helping me out here. I’m afraid I’ve already followed your orders STRICTLY and the problem persists on both games. I don’t know what else could be affecting steam in order not to be able to run both this games.

Could any other installed game interfere with steam in such way?

Thanks very much for your help so far, really.

Problem solved? I’m interested in hearing what the solution was.

Indeed, your help was much appreciated. To solve this problem I followed your steps except than I reainstalled Steam 2 times. It sounds dumb I know, is like cheking the Integrity of a game you just downloads, but the fact that I reinstalled it 2 times solved the problem and now the game works!

How I fixed gmod 12 error: Renamed steamapps to SteamApps

I am so happy i found how to fix this! If you go to the game folder(garrysmod) and then you press the organize button and then properties, you can restore to older versions! restore to a version saved a week ago or so, and you should be good! (It kinda takes a long time, but its worth it![If you want it to go faster, restore only like 7 files at a time])