Gmod Graphical Glitch

I have played gmod on steam for over 600 hours, and recently, for a unknown reason, it stopped working on my computer.

When I join a game on gmod (singleplayer or multiplayer) the screen seems normal, but when i try to move, or i move my mouse, everything just glitches out… Neither the game or the gui seems to clear after the screen gets rendered. This results in GUI adn other rendered objects overlapping each other and those no longer in view being left on the screen.

I have experienced this problem on my old computer aswell, but it did not happen on any other games, including source games, counterstrike source and Team fortress 2 works fine,

My comptuers specs are:
I7-4770k,
8Gb Ram
I don’t have a graphics card (im currently using the graphics on my processor and I suspect that to be the issue)

Any help would be great,

Thanks guys,

Fleming

There was a guy recently who had similar or same problem, it was resolved by one console command, unfortunately I can’t find his thread.

[editline]28th February 2014[/editline]

Try “mat_viewportscale 1”

[editline]28th February 2014[/editline]

If it doesn’t help, get a GPU.

thank you for helping, i tried mat_viewportscale 1 but it didnt work, it just does the same as it always does… i will get a GPU later if this threat doesnt help

Does it currently happen in other games? If yes, get the GPU.

You know what? Get the GPU either way, because what are you going to do without it?

It only happens in gmod, i tried uninstalling and re-downloading and when i loaded a map it said Node graph out of date. Rebuilding…

i dont know if thats useful or not but yeah,

im getting a GPU later, i just couldnt afford one at the time of buying the computer

Node errors are AI related issues. Particularly that error is just Source updating node graphs (AI mapping) so it works properly.

[editline]28th February 2014[/editline]

Also, you tried a lower DirectX Level?
Right click on GMod in your Steam Library, Properties, and then add to the launch options -dxlevel [90 or 80]

I tried to set the -dxlevel to 80 and 90 and neither solved the problem… thanks anyway

Integrated graphics and Garry’s Mod don’t play well together, GPU would be your easiest fix, otherwise you might spend ages trying to fix this even if there is a solution

Hey guys, so I kinda gave up on fixing it and was going to wait to get a GPU, and I realised, it worked on my old computer, and then all of a sudden, broke, and it didn’t work for the same reason before I got my new, GPU-less Computer…

So I thought, it must be a issue with steam, or rather the steam cloud that stores all the data for my profile, so I deleted the game, logged on a friends account, and re-installed GMod, I then logged back onto my steam account, and tried to boot the game.

A message came up from steam stating that the data i have on my computer is diffrent to what they have on the steam cloud, it asked me if I wanted to update the steam cloud by uploading the data I have on my computer, or if I wanted to download the data from the steam cloud.

I pressed upload to steam cloud and a few moments later, GMod booted, I then started a single player world and it worked!

Thanks guys for all the help you gave me on this issue, it means alot, I hope if any of you have a similar issue in the future this helps you guys out.

thanks again,

Fleming