GMOD Invisible Physics gun beam (NOT BLACK, BLUE)

Hello! I am playing gmod, and suddenly my physics gun beam suddenly went invisible! How can I fix this?

Hello. I have three ideas which may fix your problem. But I am not sure which, start off from the first one.

  1. By default, when you hold-down fire with phyics gun, if distance (in Source units) is less than or equal to 8000 - it draws the beam. However, if distance between your aim/hit position and your physgun muzzle (or it uses your player’s shoot/eyes) position is greater than 8000 Source units - engine won’t draw the beam.
    So, if you can’t see physgun beam while holding primary attack key while also aiming under your foot, proceed to the next possible solution; if you see the beam under your foot - you can’t fix this unless altering the code.

  2. Perhaps somebody made bad mistake(s) while scripting an addon… Disable all your addons (manually.)
    Exit GMod. Navigate to %ProgramFiles%\Steam\SteamApps\common\GarrysMod\garrysmod folder (you can paste that path into Run window and hit Enter/Return key; if you are Windows user.)
    Rename the folder called “addons” to something else (e.g. “myaddons”); if there is no “addons” folder, proceed to the next possible solution.
    So, go in-game and see if this has fixed your issue (remember aim below your foot while holding primary attack on physgun). If not, proceed next.

  3. I discovered this when I had dumped/extracted all console commands from the game…
    Go in-game. Press Escape key, Open Options dialog, “Keyboard” tab, click on “Advanced…” button, tick first option (Enable developer console), click “OK” button.
    Scroll to the bottom, set whatever key you prefer for “Toggle Console” (by default it is set to trigger by pressing key above Tab a.k.a. “~”-tilde), click “Apply” and then “OK” at Options dialog.
    Finally, press your bound key for “Toggle Console”.
    Type in (or copy+paste the following bolded text): “cl_weaponcolor” = “1.000000 1.000000 1.000000” and hit Enter/Return or click on “Submit” button.
    Type in (or copy+paste the following bolded text): “physgun_drawbeams” = “1” and hit Enter/Return or click on “Submit” button.
    Resume and enjoy the game.
    Hopefully I have solved your issue (remember aim below your foot while holding primary attack on physgun). If not, try re-installing Garry’s Mod completly.

  4. ???

The beam can also disappear if you’re running out of memory. Are you running FAS2, or any other mod that has a memory leak? That will cause an issue…

Black color will render it invisible but you say it was not the case.

Have you disabled it in the context menu? You know, the one in the upper left corner.

Not at all.

[editline]2nd March 2015[/editline]

I do not even know what FAS2 is. and I do not know any other mod that would cause a memory leak.