Gmod is failing to launch.

Yesterday it worked fine, no problems, but today I get this when trying to launch Gmod.

http://img.cx/4SY9.jpg

I have not installed any addons or anything.

Specs :
Processor : Intel Core i7
Graphics Card : 275 GTX
OS : Windows 7 - 32 Bit
RAM : 4 GB

If it helps, all my addons are done through SVN.

Er, you start out by saying “I have not installed any addons or anything” then say “I use SVN for most of my addons.” So… which is it?

I use SVN for other addons I have put on a while ago and Gmod has worked after it but when I shutdown my PC last night and turned it on today launched Gmod, done nothing else, and I get that error…

I assume you’ve taken the standard steps, verifying the game cache, and if that fails uninstalling and redownloading gmod?

Also, do other Steam games launch properly?

All of my other games are doing the same :frowning:

Fixing pipe errors in steam step’s

  1. Exit steam (File > Exit) and load it back up
  2. Restart your pc
  3. Delete the clientreg.blob

If that don’t work reinstall steam.

Dang, ninja’d. Anyway, do what the estimable benjojo said. Although from other reports with this error I’m not sure deleting the clientregistry.blob is necessary.