GMod is still not launching after the latest updates

OS: Windows 7 Home Premium (64 bit)
Processor: AMD Athlon X2 240 2.8Ghz (Dual Core)
RAM: 3GB DDR3
Video Card: Nvidia GeForce GTS 250 1GB

I haven’t been able to play Garry’s Mod in a little over 2 weeks now. After the recent update which stopped that error code from coming out on most people’s launch of GMod i can still NOT play. There’s no specific message that comes out when trying to launch it from steam. I get the normal gray box that says “preparing to launch…” and then it disappears without launching GMod. I tried checking the file integrity and defragmenting the files. I tried deleting the “local game content” without result. I even went directly into the programfiles/steamapps/jinson5/ and deleted the ENTIRE GMod folder, still nothing. The last thing i decided to do after reinstalling GMod and seeing that it wasn’t launching was to launch it through the main directories exe. file (hl2.exe). I got a message saying the following -

Setup file ‘gameinfo.txt’ doesn’t exist in sudirectory ‘hl2’. Check your -game parameter or VCONFIG setting.

What i decided to do after this was go into my garrysmod/garrysmod directory and copy the ‘gameinfo.txt’ file and paste it in the programfiles/steamapps/jinson5/garrysmod/hl2 directory which caused the game to open up and load to the MAIN MENU and crash with ANOTHER error message saying (by the way, i doubted that this would fix the problem):
‘Could not load library client’

I apologize for the long story, i just wanted to be as thorough as possible and see if anyone else was having this same issue. I looked everywhere through Google and found no one with similar issues.


Every other single game in my entire library works flawlessly. this includes TF2, HL2, HL2: episode 1, Hl2: Episode 2, CS:S, etc…

I have downloaded Garry’s Mod again and i get a new error saying the following
SteamStartup()failed:SteamStartup(0xf,0x0038E394) failed with error 1:
failed to take master pipe connection lock.

The “Master Pipe Connection Lock” error can be fixed by either restarting Steam or the computer.

I did that, the error goes away for a few of the times that i try launching GMod, but it comes back again afterwards. Even so, GMod is still not launching. =/ this is such a nuisance. I’ve even reformated my computer with high hopes. lol.